No password necessary for login to admin account

Asked by Matthew on 2017-09-02

Having changed the language of Ubuntu from french to english, and have set the admin to login without a password, I have added a password to the admin account. However, at the login page, I am not prompted a password when logging in.
I am prompted for one on other non admin accounts, and I am also prompted it when accessing root privileges or when the admin password is needed for other reasons on the whole of ubuntu.
I have checked and I cannot find a light.dm file with any auto-login data. I cannot understand how I can disable auto-login.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: lightdm 1.18.3-0ubuntu1.1
ProcVersionSignature: Ubuntu 4.4.0-93.116-generic 4.4.79
Uname: Linux 4.4.0-93-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.10
Architecture: amd64
CurrentDesktop: Unity
Date: Sat Sep 2 01:19:46 2017
InstallationDate: Installed on 2016-10-07 (329 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
SourcePackage: lightdm
UpgradeStatus: No upgrade log present (probably fresh install)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu lightdm Edit question
Assignee:
No assignee Edit question
Solved by:
Matthew
Solved:
2017-09-03
Last query:
2017-09-03
Last reply:
2017-09-02
Scott Emmons (lscotte) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs.

Scott Emmons (lscotte) said : #2

Hi, I'll try to help answer this question. It would help to describe in a bit more detail what you are seeing. Can you describe what you see in the lightdm login page - when you enter a username does it allow you to login directly as the admin user without prompting for a password, or something else?

Also when you say you changed the user's password, what commands did you use?

Finally, if you login from a virtual terminal (ctrl-alt-F1) as this admin user, does it ask for a password there? This might help narrow down if it's the lightdm configuration (of which there are several possible files), or that the user has no password configured.

Hopefully this will provide some additional direction/background information pointing to the problem.

Configuration files [1]:
/usr/share/lightdm/lightdm.conf.d/*.conf
/etc/lightdm/lightdm.conf.d/*.conf
/etc/lightdm/lightdm.conf
/etc/lightdm/users.conf

[1] https://wiki.ubuntu.com/LightDM

Matthew (themattnolan) said : #3

At the lightdm page I see my username and a connect button which only needs to be clicked in order to log in.

I used passwd , sudo passwd. I changed it to an 'easy' password briefly.

When I log in to the virtual terminal, I am able to login with my admin password. My goal is for this to happen at startup too.

Scott Emmons (lscotte) said : #4

Thanks for answering those questions. I think we can be certain that user's password is set correctly, but it is indeed something with lightdm. I am puzzled by there being a "connect" button - this almost sounds like it's a disconnected session, rather than a logged out one. My only advice there is just to insure that the lightdm session is completely closed/logged out, and not just suspended/changed. Beyond that, hopefully someone else with a bit more knowledge of lightdm will be able to help so this is resolved for you.

Matthew (themattnolan) said : #5

Sorry it says log in not connect.

Scott Emmons (lscotte) said : #6

OK, here's one more thing to check - if you login as the admin user and run "id -a" does it show your user to be in the "nopasswdlogin" group? I found this: https://askubuntu.com/questions/100010/no-password-asked-at-login-screen-just-start-session-button-with-lightdm#102222 which is a possibility (and contains instructions to remove the user from that group, if so). Worth giving that a try!

Matthew (themattnolan) said : #7

Thank you!

Scott Emmons (lscotte) said : #8

Excellent Matthew! I'm glad that solved it for you, and sorry it took a few iterations to eek out what was going on. Have a good day!