IBM Thinkpad T30 runnung Ubuntu 12.04 doesn't see DWL-G650 D-Link wireless cardbus adapter

Asked by Ron Meek on 2013-04-30

IBM Thinkpad T30 runnung Ubuntu 12.04 doesn't see DWL-G650 D-Link wireless cardbus adapter. iwconfig detects no wireless extensions. sudo lshw -C network shows only the ethernet interface and dmesg also doesn't show the card. Am sure this card was picked up and configured automatically with earlier versions of Ubuntu?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu lightdm Edit question
Assignee:
No assignee Edit question
Solved by:
Ron Meek
Solved:
2013-04-30
Last query:
2013-04-30
Last reply:
Ron Meek (ron-in-calgary) said : #1

card function strange now
sudo iwconfig lo no wireless extensions.

wlan0 IEEE 802.11bg ESSID:"TELUS6720"
          Mode:Managed Frequency:2.437 GHz Access Point: 20:76:00:03:0B:04
          Bit Rate:54 Mb/s Tx-Power=27 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=58/70 Signal level=-52 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:60 Missed beacon:0

irda0 no wireless extensions.

eth0 no wireless extensions.

but it's working, kind of.

Ron Meek (ron-in-calgary) said : #2

Well, it's still working, but only out of one slot, and not the way it's supposed to work, so I guess combo of old laptop, old card, and new o/s... and really, I've been trying to make this thing work for a long time. Guess it was just waiting to make a fool of me. Sorry to trouble you, thanks for your patience... but if it stops again, I'll be back.