Cant enter system:problem with permissions

Asked by Mauricio on 2012-12-22

Hi... I have a serious problem. I was playing with my Ubuntu 12.04 LTS root permissions for LAMP and now I cant enter to the system.

-I turn on my computer and I get the user menu.
-I enter my password for my user.
-It appears a black screen for 1 second with letters.
-Im back to the user menu.

I tried with invited user but the same thing happens.

Can someone help me please. I hope i can restore mi ubuntu =(

Thanks!

pm: im now on windows >=(

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu lightdm Edit question
Assignee:
No assignee Edit question
Last query:
2012-12-22
Last reply:
2012-12-22
N1ck 7h0m4d4k15 (nicktux) said : #1

Try this ..

When you are in login screen.. press CTLR+ALT+F2 , it will drop you to console mode.

There , login with your username & password and then give this command

rm ~/.Xauthority

proofread twice... everything matters .. dot , Capital X .. etc .. and hit [Enter] key..

Then give these 2 commands

$ sudo service lightdm stop

$ sudo service lightdm start

it will drop you to login screen again.. try now to login.

Thanks

Mauricio (mauricioantonius) said : #2

It did not work... =(

But... I kind of solved the issue without erasing my files. I installed ubuntu in another partition and mounted the old partition in the new one. Then I saw that al my folders files and subfolders were blocked only for root users. I changed the persmission from the new ubuntu partition and it finally worked.

Thanks anyway!

Can you help with this problem?

Provide an answer of your own, or ask Mauricio for more information if necessary.

To post a message you must log in.