How to disable lightdm auto login for XDMCP?

Asked by Teppo Peltonen on 2012-10-20

How to disable lightdm auto login for XDMCP? I would like to allow auto login for local desktop user and this works just fine. However, when I enable XDMCP, also the remote users are automatically logged in. How can I configure lightdm so that remote users are presented with the login and password dialog? This is my lightdm.conf:

[SeatDefaults]
greeter-session=unity-greeter
user-session=xubuntu
autologin-user=koti
xserver-allow-tcp=true

[XDMCPServer]
enabled=true

teppo@silli:~$ cat /etc/issue
Ubuntu 12.04 LTS \n \l

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu lightdm Edit question
Assignee:
No assignee Edit question
Last query:
2012-10-20
Last reply:
2012-10-20

Comment out the line:

autologin-user=koti

by changing it to:

#autologin-user=koti

Reboot to test

Teppo Peltonen (tpeltone) said : #2

Thanks Andrew, but don't you think that would affect local logins, also?

Yes, the system will stop at the login screen and you can log in as whatever username you like to the session of your choosing.

Can you help with this problem?

Provide an answer of your own, or ask Teppo Peltonen for more information if necessary.

To post a message you must log in.