XFCE - Unable to select on boot-up

Asked by John Deakin on 2012-08-19

I recently followed the guidance on UbuntuLinuxHelp (http://www.ubuntulinuxhelp.com/how-to-speed-up-your-ubuntu-after-an-update/) to try out XFCE. The installation went as indicated in the guidance but when it was restarted I could see no "cog" on my account selection screen and hence was not able to boot into XFCE.

Now every time I boot up I get a brief flash of Xubuntu quickly followed by the Ubuntu log in screen. There is no opportunity to make a selection. I am using Ubuntu 12.04.

Can anyone help in getting the option to select interfaces?

regards,
John

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu lightdm Edit question
Assignee:
No assignee Edit question
Solved by:
John Deakin
Solved:
2012-08-22
Last query:
2012-08-22
Last reply:
2012-08-22

If you run:

killall -u $USER

You can click the Ubuntu logo and select the XFCE session.

Sam_ (and-sam) said : #2

Ubuntu (Unity) session with unity-greeter is set as default.
Basically may occur conflicts when running different sessions beside Unity.

e.g. Xubuntu meta package installs lightdm-gtk-greeter.
http://packages.ubuntu.com/precise/xubuntu-desktop

Try from vte (text only): ctrl+alt+f1
sudo stop lightdm
sudo dpkg-reconfigure lightdm
sudo restart lightdm

sudo nano /etc/lightdm/lightdm.conf

## Standard content:
[SeatDefaults]
user-session=ubuntu
greeter-session=unity-greeter

If you want lightdm-gtk-greeter as greeter make it,
greeter-session=lightdm-gtk-greeter

This file contents the default display manager, which is lightdm.
/etc/X11/default-display-manager
## It contents only one line:
/usr/bin/lightdm

Sessions are being read from /usr/share/xsessions/.
Anyhow, when lightdm is the display manager it offers Xubuntu beside Ubuntu.

Back to GUI: ctrl+alt+f7
or reboot:
sudo reboot

Communities of derivatives also provide their knowledge.
http://xubuntu.org/
http://wiki.xfce.org/faq

Thanks for the help but killall -u $USER did nothing but to get me back to the log in and sudo dpkg-reconfigure lightdm failed with a long error report.

As getting Xubuntu coming up before Unity the boot up time is now being extended to no useful purpose. Could you please tell me how to get rid of XFCE/Xubuntu?

Thanks,
John

Did you change the session before you logged in again to the XFCE session?

Sorry, not sure I understand. Using killall -u $USER bombed me out of the current session and took me back to the Unity log on screen. I was not given any other option.

regards,
John

Did you click the Ubuntu logo near your username to change session?

Thank you. I have set up my mouse as left handed and the log in screen appears to default to right so nothing has ever happened with that. Seems to all work now.

Thanks again,

John

Cool