[Xubuntu] Auto-login Doesn't Work

Asked by Justin Rich on 2012-07-26

Xubuntu 12.04 on a Compaq Presario V2000 Laptop (yeah it's old)

So, I cannot get auto login to work period. I've already tried editing my /etc/lightdm/lightdm.conf file. This is what it reads:

[SeatDefaults]
user-session=xubuntu
greeter-session=lightdm-gtk-greeter
autologin-user=justin
autologin-user-timeout=0

I've tried changing it around, it appears the order doesn't change anything. I've also gone to Applications>System>Users and Groups and selected my user profile and checked the box that says that I don't have to put a password in (Suprisingly doesn't ask for the password to do this).

Anyways, all that happens is the greeter comes up and when I click on my name the screen flashes to a nosplash type display for about half a second and then goes back to the greeter without logging me in. I can kind of see some of the stuff it shows, it only took about 40 attempts... It was saying something about Plymouth failing and then something about the battery state. Any help would be greatly appreciated.

Question information

Thomas Krüger (thkrueger) said : #1

Please open a terminal run "id" and post the output here!

Justin Rich (justin-t-rich) said : #2

outut from "id" command:

uid=1000(justin) gid=1000(justin) groups=1000(justin),4(adm),20(dialout),21(fax),24(cdrom),25(floppy),26(tape),27(sudo),30(dip),44(video),46(plugdev),105(fuse),110(lpadmin),123(sambashare)

Can you give the output of:

dpkg -l | grep dm

Thanks

Justin Rich (justin-t-rich) said : #4

Output of dpkg -l | grep dm:

ii bsdmainutils 8.2.3ubuntu1 collection of more utilities from FreeBSD
ii dmidecode 2.11-4 SMBIOS/DMI table decoder
ii dmsetup 2:1.02.48-4ubuntu7.1 The Linux Kernel Device Mapper userspace library
ii dmz-cursor-theme 0.4.3 Style neutral, scalable cursor theme
ii gnome-time-admin 3.0.0-2ubuntu1 GNOME Time Administration Tool
ii iptables 1.4.12-1ubuntu4 administration tools for packet filtering and NAT
ii libcrypt-passwdmd5-perl 1.3-10 interoperable MD5-based crypt() for perl
ii liblightdm-gobject-1-0 1.2.1-0ubuntu1 LightDM GObject client library
ii libloudmouth1-0 1.4.3-8 Lightweight C Jabber library
ii libquadmath0 4.6.3-1ubuntu5 GCC Quad-Precision Math Library
ii libwildmidi-config 0.2.3.4-2.1 software MIDI player configuration
ii libwildmidi1 0.2.3.4-2.1 software MIDI player library
ii libxdmcp6 1:1.1.0-4 X11 Display Manager Control Protocol library
ii lightdm 1.2.1-0ubuntu1 Display Manager
ii lightdm-gtk-greeter 1.1.5-0ubuntu1 LightDM GTK+ Greeter
ii passwd 1:4.1.4.2+svn3283-3ubuntu5 change and administer password and group data
ii policykit-1 0.104-1ubuntu1 framework for managing administrative policies and privileges

Thomas Krüger (thkrueger) said : #5

To login without password the user has to be in the nopasswdlogin group.
You can add a user with:
sudo gpasswd -a user_name nopasswdlogin

Justin Rich (justin-t-rich) said : #6

Negatron, this is effectively the same as clicking the check box for no password on login in the Applications>System>Users and Groups. I did try this method though and rebooted and it still does the exact same thing.

Justin Rich (justin-t-rich) said : #8

If you look at my question you can note that my lightdm.conf file is already setup the proper way. Still does not work.

andy@D420:~$ cat /etc/lightdm/lightdm.conf
[SeatDefaults]
autologin-guest=false
autologin-user=andy
autologin-user-timeout=0
autologin-session=lightdm-autologin
user-session=ubuntu
greeter-session=unity-greeter

Here is mine with autologin working, if you are missing any of the lines, add them

Justin Rich (justin-t-rich) said : #10

Negative, I changed mine to exactly what yours is, except my username and my user/greeter session is different because xubuntu. No change.

Justin Rich (justin-t-rich) said : #12

This is nothing new... Adding the # in front of any line in the config files just makes it a comment and whatever reads the file ignores it as code. Still not working.

Could install xdm or gdm and remove lightdm

Sam_ (and-sam) said : #14

Maybe review lightdm.log and syslog.

Justin Rich (justin-t-rich) said : #15

Going to bed now but will check those logs when I can. Where would I find those anyways?

Also, actionparsnip that's not really an answer to fixing a problem. That's throwing the problem away and getting a new one (possibly).

Still appreciate you guys looking at this though.

Sam_ (and-sam) said : #16

/var/log/lightdm/lightdm.log
/var/log/syslog
https://help.ubuntu.com/community/LinuxLogFiles

Justin Rich (justin-t-rich) said : #17

This is the only thing that stood out while looking at /var/log/lightdm/lightdm.log:

[+941.41s] WARNING: Could not call SetLanguage: GDBus.Error:org.freedesktop.Acc$

As for /var/log/syslog... That thing is huge! I used "grep "lightdm" syslog" and only had one entry:

Jul 27 07:16:00 justin-Presario-V2000-EZ617UA-ABA lightdm: pam_ecryptfs: Passphrase file wrapped

I did encounter something that would be useful to know for future reference as well. I use the standard terminal emulator that ships with xubuntu, I tried to Select all to copy the entire lightdm.log and it only copied what was currently on the screen. What method would be the best for copying large amounts like this? And should I be using something different for working in the terminal? I remember using Konsole when I was on regular Ubuntu.

Thanks guys!

Sam_ (and-sam) said : #18

Since suggested workarounds not help on Xubuntu rather report a bug or contact Xubuntu community if the issue is known there.
http://xubuntu.org/help/

OT
> standard terminal emulator that ships with xubuntu

Maybe look into preferences keyboard bindings or it's manpage.

> Select all to copy the entire lightdm.log

Why not copy the file then or redirect the content into a file?

Can you help with this problem?

Provide an answer of your own, or ask Justin Rich for more information if necessary.

To post a message you must log in.