Ubuntu 12.04 Log in screen freezes after password

Asked by StMaus on 2012-05-14

After entering my password I get "Logging in..." forever. The menu bar options continue to work and I can Alt to a terminal and log in from command line but the Graphical login is frozen with no active processes showing.

Question information

Language:
English Edit question
Status:
Needs information
For:
Ubuntu lightdm Edit question
Assignee:
No assignee Edit question
Last query:
2012-05-14
Last reply:
2012-05-14
Pedro Peixoto (pedrospeixoto) said : #1

Try to log in unity 2d and disable the cyclic wallpaper (if enabled). This solved for me.

The bug is been fixed in
https://bugs.launchpad.net/ubuntu/precise/+source/unity-greeter/+bug/986967

StMaus (stmaus-comcast) said : #2

Unity 2D has the same problem. I don't have cyclic wallpaper activated.

Barry Drake (b-drake) said : #3

How did you get 12.04? If an upgrade, how did you do the upgrade? Are you dual booting? If so, is Ubuntu a wubi installation? If it was an upgrade, please burn a live-CD and see if 12.04 will run directly from the live CD.

Sam_ (and-sam) said : #4

Maybe try workaround #4 (rename or rm ~/.Xauthority) and reboot.
https://bugs.launchpad.net/unity-greeter/+bug/986967/comments/4

Anyway, I'd work from tty: ctrl+alt+f1
sudo stop lightdm
sudo dpkg-reconfigure lightdm
sudo restart lightdm
or
sudo service restart lightdm
or
sudo reboot

Verify if lightdm is default dm:
nano /etc/X11/default-display-manager

Content should be:
/usr/sbin/lightdm

Basically clean-up and update to exclude broken/missing package story.
apt-get clean
apt-get autoremove
apt-get update
apt-get upgrade
apt-get -f install

StMaus (stmaus-comcast) said : #5

It's 12.04 amd64 installed from live-CD with no dual boot, sda1 ext4 /, sda3 ext4 /Home, sda5 swap. It runs fine from live-CD. I also tried to re-install and update the first time the problem appeared, that solved it for a little while. It seems to appear after several successful boots.

StMaus (stmaus-comcast) said : #6

Got as far as nano in #4, I'll try the rest when I have net access.

StMaus (stmaus-comcast) said : #7

I tried all of #4. It didn't work.

Barry Drake (b-drake) said : #8

Just a thought ... I've seen a few comments in which there was a problem of some kind, and each of these had a separate /home partition. Just thinnking out loud .... I wonder .... ?

Can you help with this problem?

Provide an answer of your own, or ask StMaus for more information if necessary.

To post a message you must log in.