12.04 Login (lightdm) problem

Asked by Chet Mistry on 2012-05-07

I've recently upgraded to 12.04 and seem to be having problems when I try to login to my account using lightdm. Whenever I try to login using my username and password the screen goes blank for a second, then I see the Nvidia logo and then the screen returns to the login screen.

I've reset my password as root (tty1 accepts it) and I've also tried removing lightdm and then reinstalling. No success with either. As a workaround I'm using gdm to login (which works) but I much prefer the lightdm interface. Numerous people seem to be having the same issue so I wanted to know if a fix was in place or if anyone knows what the real problem is?

Any help would be appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu lightdm Edit question
Assignee:
No assignee Edit question
Solved by:
Chet Mistry
Solved:
2012-05-08
Last query:
2012-05-08
Last reply:
2012-05-07

If you select unity2d session, is it ok?

Chet Mistry (c-mistry) said : #2

No, I've tried 2d and Gnome and all of the other options but none seem to work.

On the login screen press CTRL+ALT+F1

log in and run:

sudo apt-get clean

then press CTRL+ALT+F7 and attempt to log in

Chet Mistry (c-mistry) said : #4

I tried 'sudo apt-get clean' but no success, after entering my password it still reverts back to the login screen.

If you run:

df -h

Do your partitions have some free space (more than 5%)?

Chet Mistry (c-mistry) said : #6

I ran df -h and I'm not using any more than 35% on my drives. Anything else I should be checking?

run:

sudo chown -R $USER:$USER $HOME

To make sure you are the owner of your own home folder.

Chet Mistry (c-mistry) said : #8

Ok, my user account is called 'chet' so I ran the following command;

sudo chown -R chet:chet /home

and I got this response;

cannot access '/home/chet/.gvfs' : permission denied

Is this what you'd expect? What should I do next?

Chet Mistry (c-mistry) said : #9

After reading a few posts concerning the same issue I had a go at removing the Xauthority file using the command;

sudo rm ~/.Xauthority

This seems to have done the trick and I can now login to my user account using lightdm. Hope this helps other users having the same issue.

Chet Mistry (c-mistry) said : #10

ps. Thanks for your time and help Andrew :) (actionparsnip)