Password Problem

Asked by dave on 2012-04-04

Hi

I am new to ubuntu, I wanted to remove password at log on and followed these instructions :

 http://ubuntuguide.net/how-to-login-without-password-in-ubuntu-11-10

I followed the instructions ,because I wanted to log in without being asked for a password in Ubuntu 11.10.I changed my password into “none” using “user accounts” —>”login options”.
Now when I start my computer I am asked for a password ,but it is sufficient to press “Enter” to get rid of that request.The unpleasant thing is that when I want to do administrative tasks ,a password is asked and the computer will not accept my old password which I used before ,nor any other password

Any help would be much appreciated

Thank you

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu lightdm Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-04-04
Last query:
2012-04-04
Last reply:
2012-04-04

you can enable autologin in lightdm:

So, get to a Terminal and run:

gksudo gedit /etc/lightdm/lightdm.conf

If you are doing it from the console, you would need to use 'nano' instead of 'gedit' and 'sudo' instead o 'gksudo'.

In the file that opens up, enter this text:

[SeatDefaults]
autologin-user=<USERNAME>
autologin-user-timeout=0
user-session=ubuntu
greeter-session=unity-greeter

Replace '<USERNAME>' with your username and 'ubuntu' with your preferred session if you want to automatically log in to some other session than regular Unity. These are the most common session options:
'Ubuntu' (regular Unity) :
'Ubuntu 2D' (Unity 2D) :
'GNOME' (Gnome Shell) :
'GNOME Classic' :
'GNOME Classic (No effects)' :
'ubuntu'
'ubuntu-2d'
'gnome-shell'
'gnome-classic'
'gnome-fallback'

dave (barrysheen) said : #2

Hi Andrew
  This fix may well work, the problem I have since disabling my password for log in...as advised is that my password is no longer accepted in the terminal

Thx

dk

Hold shift at boot, select recovery mode and select root. Then run:

passwd foo; reboot

change foo for your username. Eg:

passwd andy; reboot

You can now use your new password. When you use sudo in a termnal you wil not get any feedback.

dave (barrysheen) said : #4

Sorry.... not accepting my new password, I would try a clean reinstall but i dont want to lose all my files.

dave (barrysheen) said : #5

Thanks actionparsnip, that solved my question.

dave (barrysheen) said : #6

Andrew

Thanks for your help, I hadn't chosen the option to remount / as read/write, all sorted now thank you :)

Get a backup