black screen can't login

Asked by hugo on 2011-12-11

when i try to login a black screen pops up with certain messages one of them is couldn't acquire lock retrying...

all others have an ok on the far right side of the screen it just lasts like second and goes back to the login screen
please help

this is ubuntu 11.10 which is wierd because as far as i'm aware i had ubuntu 10.04

when it got upgraded i have no idea but anyways please help

i'm a begginer on ubuntu resent member

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu lightdm Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2011-12-11
Last query:
2011-12-11
Last reply:
2011-12-11

Seems this bug https://answers.launchpad.net/ubuntu/+source/lightdm/+question/181587

Please try to install gdm

Press ctrl+alt+F1 made login with your user and password then type:

sudo apt-get update
sudo apt-get install gdm

if asked made gdm as default login manager

sudo reboot

Jacobsallan (jacobsallan) said : #2

What helped for me is to login in safe mode, go to my home directory, and then to examine the contents of the file .xsession-errors. In my case there were references to a third-party program that was incompatible with Oneiric (an Oracle database). The references were in my .profile and .bashrc files.

hugo (jaz-hugo143) said : #3

Thanks marcobra (Marco Braida), that solved my question.