Boot up Ubuntu 11.10 Oneiric in text mode

Asked by Tong Sun on 2011-11-07


How to boot up Ubuntu 11.10 Oneiric to console instead of GUI?

Ubuntu 10.10 Maverick used something other than traditional method, now I need to find that out for Ubuntu 11.10 Oneiric again.


Question information

English Edit question
Ubuntu lightdm Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Sam_ (and-sam) said : #1
Tong Sun (suntong001) said : #2

"Replacing quiet splash with text will leave you at a login prompt."

That's what I did. It works for my Ubuntu 10.10 Maverick.
Are you sure it works for Ubuntu 11.10? Because the post was answered at Dec 6 '10, even before 11.04.


Sam_ (and-sam) said : #3

I'm not aware of why it shouldn't work, no reference found that parameter was skipped. Looking at other answers on the page right hand side finds the same answer for 11.04

Tong Sun (suntong001) said : #4

I think all existing answers gear towards gdm, but as you said, "Oneiric uses lightdm as default instead of gdm".
So this is more or less a lightdm issue then.


Tong Sun (suntong001) said : #5

Solve it heave-handedly because I don't have time to fool around:

 % apt-get remove lightdm
 Reading package lists... Done
 Building dependency tree
 Reading state information... Done
 The following packages will be REMOVED:
  lightdm ubuntu-desktop
 0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
 After this operation, 500 kB disk space will be freed.

It works, yet that's brutal.
Still wondering how to do it "polity".


Sam_ (and-sam) said : #6

Does it mean you've tried it with lightdm and it didn't work?

Tong Sun (suntong001) said : #7


Sam_ (and-sam) said : #8

Again an interesting matter. Wasn't successful here with:
or "text".
I've looked in lightdm.conf but didn't find a clue. Maybe it's only available via ctrl+alt+f1 and then
sudo service lightdm stop
I've asked somewhere else to do a little brainstorming and report back.

Tong Sun (suntong001) said : #9

On Wed, Nov 9, 2011 at 4:55 PM, Sam_
<email address hidden>wrote:

> Again an interesting matter

Thank you Sam for your persistent!

Best Sam_ (and-sam) said : #10

Try again now, it was due to lightdm.upstart, I've attached bug report. Update came in today.

Tong Sun (suntong001) said : #11

Thanks Sam_, that solved my question.

Tong Sun (suntong001) said : #12

On Thu, Nov 10, 2011 at 6:15 PM, Sam_
<email address hidden>wrote:

> Try again now, it was due to lightdm.upstart, I've attached bug report.
> Update came in today.

The bug "was fixed in the package lightdm - 1.0.6-0ubuntu2"

Hmm... sorry I'm not quite clear how Ubuntu bug fixes populate to end user.

- currently the official release is still 1.0.1-0ubuntu6, correct (ref A)?
- how to get the latest bug fixes?


Ref A:

$ apt-cache policy lightdm
  Installed: 1.0.1-0ubuntu6
  Candidate: 1.0.1-0ubuntu6
  Version table:
 *** 1.0.1-0ubuntu6 0
        500 oneiric/main amd64 Packages
        100 /var/lib/dpkg/status

Tong Sun (suntong001) said : #13

Yep, having enabled oneiric-updates and installed lightdm - 1.0.6-0ubuntu1, I'm able to boot to text now.

thanks again