Ubuntu

gmd & lightdm doesn't ask for password and wont let me select desktop

Asked by unixchaos on 2011-10-27

ok since my upgrade i have an issue with lightdm and gdm. with either display manager it wont let me enter a password. i get to the screen for GDM cause that is what i am using right now. and i click my name and it logs in. autologin is not enabled. but i dont liek this cause it provides a security risk and worse of all im forced to use unity. lxdm works but it gives me issues when i load gnome-shell and kdm is an absolute fail just keeps restarting. i completely re-installed ubuntu as well as uninstalled ubuntu-desktop and *-desktop. and all the default configurations and rebuilt the system by hand. also ran locate gdm and removed it every place i found it on \ . and once i build it back up i get the same issue and i can use a trminal to boot into my environment of choice but this is really just so confusion. and more then anything i just want to know whats going on and how to fix it. thanks

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu lightdm Edit question
Assignee:
No assignee Edit question
Last query:
2011-10-31
Last reply:
2011-11-06

You aren't forced to use Unity AT ALL. You are completely free to install another desktop like KDE or XFCE (for example). You can even install gnome-session-fallback. One of the fundamental principals of Linux is it is CHANGABLE and CUSTOMIZABLE so saying you ae forced to use something contravenes this entirely and furthermore is not true.

Try:

sudo dpkg --reconfigure lightdm

May help.

What happens when you log in. You never said?

unixchaos (jza873) said : #2

i know i can use different interfaces. im not new at this. i have alike 10 diffetent desktop managers and window managers installed. but what i was saying is i boot up i get the gdm or lightdm screen i click my username and it logs on. dosnt let me switch the windo manager or enter a password. and i tried the reconfigure with gdm kdm lightdm the only time it worked for me was on lxdm. also tried removeing .Xauthority no good

Sam_ (and-sam) said : #3

Lightdm is default display manager?
Bug #864174

Maybe move ~/.dmrc.
Bug #824921

Any clue in log files?

unixchaos (jza873) said : #4

thanks sam but yea neither of those links provides info for what is happening. its like of like login with no password is set. i get to the gdm screen and i see my username and other. i have gdm as default. all these issues happens exactly the same as with Lightdm except in light dm i can pick my window manager cause of the little gear icon. but as for gdm. as soon as i click on my name it just logs me into what ever the default session is. in this case unity. with lightdm i pcik my WM and then click teh login button. with both it never prompts me for a password. now if i switch to say lxdm it has the username and password box a little different. you have to type it in VS clicking a username. thw whole clicking username is what i like. i just dont know what would be causing this. logs dont have any useful info. also gdm config files dont say anything. at least from what i can see. its all just generic gdm info. let me know if you want me to post any thing. its been a while since i needed to turn to launchpad for help. but this one is even beyond me..

unixchaos (jza873) said : #5

can anybody help

Look in
/etc/lightdm/lightdm.conf

and
 /etc/lightdm/lightdm.conf

Make sure autologin and stuff is not enabled. May help

Sam_ (and-sam) said : #7

Seems some config gets confused over using gdm and lightdm together. I'd say report a bug via apport in order to submit logfiles to triage what's going on.

Can you help with this problem?

Provide an answer of your own, or ask unixchaos for more information if necessary.

To post a message you must log in.