How to remove names from login screen?

Asked by Mannex on 2011-10-15

It seems to me that security is one step tighter when login names are not displayed on the login screen, but have to be entered. I used to be able to do this in 11.04 fairly easily. How do I do it in 11.10?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu lightdm Edit question
Assignee:
No assignee Edit question
Solved by:
Mannex
Solved:
2011-10-16
Last query:
2011-10-16
Last reply:
2011-10-15
Benjamin Tegge (livewirebt) said : #1

Assuming that you still want to have some names shown at the login screen, this might help:

This is not lightdm specific, the following workaround also applies for GDM and probably other display managers, too. When user accounts are created, they are assigned a UID and GID in a specified range. These ranges are specified in /etc/login.defs with the following variables: UID_MIN, UID_MAX, GID_MIN and GID_MAX. The display manager shows users in the range specified by UID_MIN and UID_MAX.

So you could either assign a UID (and GID) lower than UID_MIN (default 1000) to the user with the usermod command or you could modify UID_MIN. Changing uservariables with the usermod command requires another administrative user, but I would recommend that method over editing config files.

There is one drawback to this workaround: Your name will not be shown in the panel, instead it will show »[Invalid UTF8]«.

Mannex (russ-mannex) said : #2

Thanks. I was actually aware of that workaround, but it's hideously ugly. Why isn't there a way to do this with the login manager? It seems ridiculous to not have the option, especially since it removes one more layer of security. Very bad.

Can I install an alternate login manager that WILL allow me to do this?

Mannex (russ-mannex) said : #3

OK, well since there doesn't seem to be any additional help, here's how I resolved it. I dumped Unity for KDE Plasma. You can configure the login there.

Mannex (russ-mannex) said : #4

For future reference in case someone else has the same problem, go to /etc/lightdm and add the following line to the lightdm.conf file:

greeter-hide-users=true

That should do it.