Oneiric ALPHA 2 on ACER Aspire One AO532h. After updates I can't login

Asked by Mark Nighswonger on 2011-07-19

When I install the iso there are some glitches that are well documented and apparently dealt with already in the updates. Apport will not file a bug because newer versions are available and it prompts me to update. When I update, the first thing I get is this:
Not all updates can be installed
Run a partial upgrade, to install as many updates as possible.
So far, when I have updated I get to the login screen and hit enter to select user, or try to select with cursor. Instead of prompting me for a password, the login screen vanishes, leaving me a cursor on, what appears to be, the desktop background with no interface options.
I have tried booting the repair OS to try to repair any broken packages. That doesn't work. I can get to a tty and login but I don't know what to do.
I've repeated the fresh iso install (the check sum is correct), and tried updating several times hoping some new update will get me to the desktop. I have been using the sudo update-manager -d command. This is correct for me isn't it?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu lightdm Edit question
Assignee:
No assignee Edit question
Last query:
2011-07-19
Last reply:
2011-07-20

As you probably know, Oneiric is the development branch and these sorts of problems are to be expected. However, depending on various factors (described below), you may be able to help the Ubuntu project by reporting this as a bug.

The command "sudo update-manager -d" attempts to upgrade your Ubuntu system to a new release of Ubuntu. You could use it to upgrade a Natty system to Oneiric. To install updates to your existing Ubuntu system (including this Oneiric system) using the Terminal, run:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

Assuming that completes successfully and the problem still occurs after rebooting (in a virtual console, you can reboot properly with Ctrl+Alt+Delete or by running "sudo reboot"), and there is no bug currently filed for this, you should file a bug against lightdm in Ubuntu using Apport (invoke ubuntu-bug with the PID of the currently running lightdm process). Before doing so, please read https://help.ubuntu.com/community/ReportingBugs carefully. That explains how to search for reported bugs, that should enable you to make sense out of my instructions for how to invoke ubuntu-bug, and it contains significant additional information about how to report bugs and what kind of information to include in your bug reports.

If you find a bug for this or report one, please link it and this question together using the "Link existing bug" link near the top of the page. However, your bug report should be complete and self-contained; it should not be necessary for Ubuntu developers to refer to this question page in order to fully understand and appreciate your bug.

You can press CTRL+ALT+F1 on the logon screen, logon there and run:

sudo apt-get -f install; sudo apt-get update; sudo apt-get -y dist-upgrade

Does it install the updates ok?

Mark Nighswonger (marknigh) said : #3

I tried all of the above. She updates just fine, it's just the login screen that's buggy! I couldn't get a UI to do ubuntu-bug, so i did the apport command and then downloaded W3M to follow up. (At least I learned something)
Back to square one.

I'm sorry, I had misinterpreted your problem. This is (almost certainly) not a bug in lightdm. This is a bug in Unity (or Compiz) or unity-2d (or metacity) instead. The best way to report this is to mark your existing report Invalid (I just did that) and file a new report against unity. Use a command like "ps ax | grep -v grep | grep unity" to get the PID of the running unity or unity-2d process, then initiate the bug report by invoking ubuntu-bug or apport-cli with that process ID number.

If you do report this by invoking ubuntu-bug or apport-cli with a package name (which is less preferable in this situation, because running process state information may be useful), then please make sure to report it against unity if you're running 3D Unity, but against unity-2d if you're running unity-2d. (You can use the ps command as detailed above to see whether the unity-related executable image names say unity-2d or not.)

Before reporting this against unity in Ubuntu, you should search existing bugs in unity in Ubuntu (https://bugs.launchpad.net/ubuntu/+source/unity/+bugs), the Unity project (https://bugs.launchpad.net/unity/+bugs), and compiz in Ubuntu (https://bugs.launchpad.net/ubuntu/+source/compiz/+bugs). Or if you're running unity-2d rather than 3D Unity, you should search for existing bugs in unity-2d in Ubuntu (https://bugs.launchpad.net/ubuntu/+source/unity-2d/+bugs), the unity-2d project (https://bugs.launchpad.net/unity-2d/+bugs), and metacity in Ubuntu (https://bugs.launchpad.net/ubuntu/+source/metacity/+bugs).

If you are running 3D Unity rather than unity-2d and you are able to open a graphical Terminal window over the blank desktop by pressing Ctrl+Alt+T, then you should specify in the bug report whether or not any of "unity --replace", "unity --reset", or "compiz --replace" (temporarily) fixes the problem. Open a new Terminal window for each of these commands, and make sure you have a prompt ($ _) when you type them in. Trying them in that order, once you get one of them to work, you don't need to try another (unless a developer posts in the bug to indicate that you should).

So actually I hadn't misinterpreted your question; I just managed to convince myself that I had, and then on the basis of that reasoning, I gave you a whole bunch of bad advice. Fortunately, Brendan Donegan saw my mistaken, and I didn't irreversibly ruin the fruits of your efforts and my once-good advice. I have marked bug 813390 back from Invalid to New, and work can proceed on it there. You should *not* report this as a bug in unity (nor unity-2d) after all.

Sorry!

Mark Nighswonger (marknigh) said : #6

Okay. So at this point I believe that we have accomplished what needs to be done and I will just wait for any new requests for further information.

Can you help with this problem?

Provide an answer of your own, or ask Mark Nighswonger for more information if necessary.

To post a message you must log in.