How to disable screen locking

Asked by Hungerburg on 2014-03-23

Recently got me xubuntu 14.04 beta; It has light-locker active by default or so it reads in the advertisement.

A very annoying feature is, that when the screen goes dark, immediately thereafter the screen is locked too, and I have to enter my password to reactivate the session.

I have installed light-locker-settings too, which seems to not use dconf and has its very own timeouts, at least thats what it looks like. "Lock automatically after screensaver" is OFF there, still blanking the screen locks it still.

Additionally, in xfce4-power-manager-settings screen locking on standby is disabled. I have tried the following in dconf to no avail too:

[org/gnome/desktop/lockdown]
disable-lock-screen=true

[org/gnome/desktop/screensaver]
ubuntu-lock-on-suspend=false
lock-enabled=false

Pleaset tell me, how to make blank screen _not_ lock screen.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu light-locker Edit question
Assignee:
No assignee Edit question
Solved by:
Hungerburg
Solved:
2014-03-23
Last query:
2014-03-23
Last reply:
2014-03-23

Uninstall the current screensaver and install xscreensaver. You can then set no screensaver.

Also check for, and report a bug. Trusty is not finished and not ready or stable.

Hungerburg (pch-myzel) said : #2

I do not have any screensaver installed. Just blanking is fully OK with me.

There is no bug on the subject. I have queried launchpad with thre different keyword combinations and looked quite a little at the result lists. At the moment, I do not even know, which app or service locks the screen… gnome-power-manager is not installed, just the xfce one.

Hungerburg (pch-myzel) said : #3

Now I have disabled locking from light-locker at all and the screen goes blank after the timeout specified in power-manager settings and it does not lock. A little puzzled, what light-locker is good for, seems to be no use for me, at least… Please excuse the noise