liferea cannot create subscription for linuxtoday

Asked by marco.pallotta on 2009-03-09

In liferea (either in Hardy or in Intrepid) if you try to add rss feed of linuxtoday (http://linuxtoday.com/biglt.rss) you obtain an error: there were errors while parsing this feed (no problems with any other news reader software I have tried before). If you try to read parser error detail you can read:

"Could not detect the type of this feed! Please check if the source really points to a resource provided in one of the supported syndication formats!
XML Parser Output:
XML Parser: Could not parse document:

Entity: line 54:

parser

error :

Input is not proper UTF-8, indicate encoding !
Bytes: 0x85 0x72 0x65 0x61

:</b> "I am delighted that someone's Aunty Foo or Grandma Bar uses Linux

                                                                              ^

XML error while reading feed! Feed "http://linuxtoday.com/biglt.rss" could not be loaded!Could not determine the feed type."

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu liferea Edit question
Assignee:
No assignee Edit question
Solved by:
marco.pallotta
Solved:
2009-03-10
Last query:
2009-03-10
Last reply:
2009-03-09
Torsten Franz (torsten.franz) said : #1

Hi,

it is the same problem in my liferea. Do you can informate the website-manager that his rss feed is not valid.

Here is the link to check it out:
http://feedvalidator.org/check.cgi?url=http://linuxtoday.com/biglt.rss

Greetz
Torsten

Bernhard (b.a.koenig) said : #2

There seems to be a bug in the xml, it works as a firefox live bookmark though.

But why does it work with firefox, igoogle, knode and not with liferea?
feedvalidator says the problem is in the feed so liferea should be right but this means that firefox, igoogle and knode are wrong.

Bernhard (b.a.koenig) said : #4

Not wrong, they are just skipping over the problematic lines of code. The firefox live bookmark of this site looked fine to me, everything was there.

Today the problem was fixed by linuxtoday.