Where is libzrtpcpp-dev in Ubuntu 20?

Asked by Sjef Bosman on 2020-10-14

Trying to compile twinkle from the sources. There is a newer version available than the distributed version.
Now stuck because there is no libzrtpcpp-dev package available on Ubuntu 20, apt-get gives me: Unable to locate package libzrtpcpp-dev

Thanks for your reply!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu libzrtpcpp Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2020-10-14
Last query:
2020-10-14
Last reply:
2020-10-14

Do you mean Ubuntu 20.04 (Codenamed Focal and is LTS) or Ubuntu 20.10 (Codenamed Groovy and is still in pre-release).

"Ubuntu 20" doesn't exist. It's not a thing

Manfred Hampl (m-hampl) said : #2

libzrtpcpp has not been provided in Ubuntu releases since the year 2016, because it has long-standing bugs that nobody cared to correct.

see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=847316

But why do you want to compile twinkle from source? There is a binary package in the Ubuntu repositories which does not depend on libzrtpcpp.

sudo apt install twinkle

Sjef Bosman (sjef.bosman) said : #3

Thanks Manfred.

I have twinkle (1.10.1) installed, from the repositories, but the twinkle website and github both mention a newer version: 1.10.2. Recently, the installed version started to act buggy, no clue as to why: can no longer call, it loops internally, can't quit properly.

So I set up a little project to recompile twinkle from the sources. I didn't check the sources, but apparently there is a reference to libzrtpcpp somewhere, which cannot be resolved obviously.

Any suggestions, except for "forget it, use a different SIP client"? Thanks!

PS Of course I meant Ubuntu 20.04 LTS...

Best Manfred Hampl (m-hampl) said : #4

Ideas:

There is a package bzrtp (libbzrtp-dev) in Ubuntu focal, I do not know whether that can replace libzrtpcpp-dev in twinkle.

The Ubuntu twinkle package has been compiled with -DWITH_ZRTP=OFF, which seems to eliminate the need for libzrtpcpp-dev. (I do not know whether the software then still does what you expect).

What is the output of:

lsb_release -a; uname -a

Thanks

Sjef Bosman (sjef.bosman) said : #6

Thanks Manfred Hampl, that solved my question.

Sjef Bosman (sjef.bosman) said : #7

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.04.1 LTS
Release: 20.04
Codename: focal
Linux sjef-HP-Z420-Workstation 5.4.0-51-generic #56-Ubuntu SMP Mon Oct 5 14:28:49 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Then it's Ubuntu 20.04 and not Ubuntu 20.