Can libxml2-dev have libxml2 dependency > 2.8.0+dfsg1-5ubuntu2.4

Asked by Yong Lee

I am trying to install libxml2-dev package by doing sudo apt-get install libxml2-dev and I am getting the following error:
 libxml2-dev : Depends: libxml2 (= 2.7.8.dfsg-5.1ubuntu4.9) but 2.8.0+dfsg1-5ubuntu2.4 is to be installed E: Unable to correct problems, you have held broken packages.

How can I resolve this problem for my Ubuntu 12.10?

Question information

English Edit question
Ubuntu libxml2 Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
michael (yellupcm-gmail) said :

Please read site below. 12.10 is no longer supported, please update to a supported release.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

I suggest you wipe Quantal off your system and do a clean install of trusty (Ubuntu 14.04)

Trusty is LTS and gives support til April 2019

Can you help with this problem?

Provide an answer of your own, or ask Yong Lee for more information if necessary.

To post a message you must log in.