how do I install the package I need without dependancies of dependancies of dependancies ...

Asked by Steve

I want to run runescape on linux, but it needs a package.
The package won't install because it needs 3 more packages
each of the 3 packages have at least a dozen more dependant packages
Is there any way to get all the dependancies without searching, downloading and installing everything one at a time?

Question information

English Edit question
Ubuntu libx11 Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Revision history for this message
Manfred Hampl (m-hampl) said :

If you use the package management programs (apt-get, synaptic, ...) to install a package, all packages that this depends on will be automatically installed, too.

But probably easier, have you tried following ?

Revision history for this message
Steve (stew-ozone) said :

Thank you very much!

I found apt-get and synaptic whilst waiting for a response and tried to install them, only to find I didn't have the required dependancies!!!!!!!!!

I've followed the instructions in the link you provided, but that's not happy - I think some of the packages I already installed are getting in the way.

I think I just forced an update of everything on my computer - it's taking ages.

Revision history for this message
Steve (stew-ozone) said :

OK That's not worked. As I only installed Ubuntu yesterday, I'll start again with a clean system.

Revision history for this message
Manfred Hampl (m-hampl) said :

If you have an Ubuntu installation, you will have apt-get installed in any case.

Please provide the output of the following commands

uname -a
lsb_release -crid
dpkg -l | grep apt

(unless you have already started reinstalling your system).

Revision history for this message
Steve (stew-ozone) said :

I had to re-install, the update changed my shell - and prevented the O/S from restarting.

Working afresh, I'm now stuck because it needs JDK1.6, or 1.7. I managed to install 1.8, but that's not good enough. Here's what I get back from the commands you asked for:

steve@steve-ProLiant-MicroServer:~$ uname -a
Linux steve-ProLiant-MicroServer 4.4.0-31-generic #50-Ubuntu SMP Wed Jul 13 00:07:12 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

steve@steve-ProLiant-MicroServer:~$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 16.04.1 LTS
Release: 16.04
Codename: xenial

steve@steve-ProLiant-MicroServer:~$ dpkg -l | grep apt
ii apt 1.2.12~ubuntu16.04.1 amd64 commandline package manager
ii apt-transport-https 1.2.12~ubuntu16.04.1 amd64 https download transport for APT
ii apt-utils 1.2.12~ubuntu16.04.1 amd64 package management related utility programs
ii aptdaemon 1.1.1+bzr982-0ubuntu14 all transaction based package management service
ii aptdaemon-data 1.1.1+bzr982-0ubuntu14 all data files for clients
ii apturl 0.5.2ubuntu11.1 amd64 install packages using the apt protocol - GTK+ frontend
ii apturl-common 0.5.2ubuntu11.1 amd64 install packages using the apt protocol - common data
ii laptop-detect 0.13.7ubuntu2 amd64 attempt to detect a laptop
ii libapt-inst2.0:amd64 1.2.12~ubuntu16.04.1 amd64 deb package format runtime library
ii libapt-pkg-perl 0.1.29build7 amd64 Perl interface to libapt-pkg
ii libapt-pkg5.0:amd64 1.2.12~ubuntu16.04.1 amd64 package management runtime library
ii libatk-adaptor:amd64 2.18.1-2ubuntu1 amd64 AT-SPI 2 toolkit bridge
ii libmjpegutils-2.1-0 1:2.1.0+debian-4 amd64 MJPEG capture/editing/replay and MPEG encoding toolset (library)
ii libmpeg2encpp-2.1-0 1:2.1.0+debian-4 amd64 MJPEG capture/editing/replay and MPEG encoding toolset (library)
ii libmplex2-2.1-0 1:2.1.0+debian-4 amd64 MJPEG capture/editing/replay and MPEG encoding toolset (library)
ii libopencore-amrnb0:amd64 0.1.3-2.1 amd64 Adaptive Multi Rate speech codec - shared library
ii libopencore-amrwb0:amd64 0.1.3-2.1 amd64 Adaptive Multi-Rate - Wideband speech codec - shared library
ii libpcap0.8:amd64 1.7.4-2 amd64 system interface for user-level packet capture
ii libraptor2-0:amd64 2.0.14-1 amd64 Raptor 2 RDF syntax library
ii python-apt-common 1.1.0~beta1build1 all Python interface to libapt-pkg (locales)
ii python3-apt 1.1.0~beta1build1 amd64 Python 3 interface to libapt-pkg
ii python3-aptdaemon 1.1.1+bzr982-0ubuntu14 all Python 3 module for the server and client of aptdaemon
ii python3-aptdaemon.gtk3widgets 1.1.1+bzr982-0ubuntu14 all Python 3 GTK+ 3 widgets to run an aptdaemon client
ii python3-aptdaemon.pkcompat 1.1.1+bzr982-0ubuntu14 all PackageKit compatibilty for AptDaemon
ii toshset 1.76-4 amd64 Access much of the Toshiba laptop hardware interface
ii update-manager 1:16.04.3 all GNOME application that manages apt updates
ii xserver-xorg-input-synaptics 1.8.2-1ubuntu3 amd64 Synaptics TouchPad driver for X.Org server

Revision history for this message
Best Manfred Hampl (m-hampl) said :

Ubuntu 16.04 provides openjdk-8 and openjdk-9, but no more the -6 and -7 versions.

I see the following options for you:

1. Ask the providers of the runescape program that they modify their package that it works also with openjdk-8 as provided by Ubuntu 16.04

2. Try installing a version of openjdk-7 on your Ubuntu 16.04 system, e.g. by adding the PPA to your list of software sources.

3. There is a PPA with a unix-runescape-client package for Ubuntu 16.04, see

4. Other possibilities (like building openjdk-7 packages on your system) are feasible, but more complicated.

Revision history for this message
Steve (stew-ozone) said :

Option 1 really needs to be to ask Jagex to get their installer to work properly. It's supposed to be a known problem, but it's not fixed yet (I just tried the "official" install again).
Option 2 is the one I'll try next.
Option 3 is the one I'm struggling with. kikariknight's package wants the deprecated versions of JDK
Option 4 is complicated; I already downloaded the software, but I'm struggling with the installation instructions. I'll come back to it if option 2 doesn't work.

Revision history for this message
Steve (stew-ozone) said :

Thanks Manfred Hampl, that solved my question.

Revision history for this message
Steve (stew-ozone) said :

Thank you again. I can now get back to the more tedious task of re-aquiring my max cape.

At least I'll have something to come back to when it gets too much.