KVM does'nt recognized hardware acceleration on Intel Q9300

Asked by Anders Wallenquist on 2008-06-25

I cant use hardware acceleration with Virt-manager or virsh and KVM

aw@usbs:~$ uname -a
Linux usbs 2.6.24-19-xen #1 SMP Wed Jun 18 16:08:38 UTC 2008 x86_64 GNU/Linux
aw@usbs:~$

aw@usbs:~$ egrep '(vmx|svm)' /proc/cpuinfo
flags : fpu de tsc msr pae mce cx8 apic sep mtrr mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good pni monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr sse4_1 lahf_lm

(Intel Core 2 Quad Q9300)

Virtualisation is on in BIOS.

aw@usbs:~$ virsh --connect qemu:///system
Connecting to uri: qemu:///system
Välkommen till virsh, den interaktiva terminalen för virtualisering.

Skriv: 'help' för hjälp med kommandon
       'quit' för att avsluta

virsh # capabilities
<capabilities>
  <host>
    <cpu>
      <arch>x86_64</arch>
    </cpu>
  </host>

....
I believe the response whould include some <vmx> above.

the "Use hardware acceleration" checkbox in the wizard is greyed out

I have also problem connecting to the Xen hypervisor

aw@usbs:~$ virsh --connect xen:///system
Connecting to uri: xen:///system
fel: misslyckades att ansluta till hypervisor
aw@usbs:~$

I think this is another problem.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu libvirt Edit question
Assignee:
No assignee Edit question
Last query:
2008-06-25
Last reply:
2008-06-26
bodhi.zazen (bodhi.zazen) said : #1

did you add your user to the libvirtd group?

sudo adduser `id -un` libvirtd

log out and back in ...

Can you start kvm from the command line ?

kvm -cdrom ubuntu.iso -hda ubuntu.img -m 512 -boot d

Can you help with this problem?

Provide an answer of your own, or ask Anders Wallenquist for more information if necessary.

To post a message you must log in.