Package libusb-dev for 20.04.3 does not properly link

Asked by Mike Riley

The file should be symbolically linked to, but instead is a text file with these contents:
/* GNU ld script. */
GROUP ( /lib/x86_64-linux-gnu/ )

Once I create the symbolic link my program that uses works properly. Prior to that I get unresolved symbols for the API functions my code was calling.

I just want to verify if this is a known bug, or should I file a bug report to get it fixed?

Mike Riley

Question information

English Edit question
Ubuntu libusb Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Revision history for this message
Best Manfred Hampl (m-hampl) said :

Are you sure that you aren't confusing libusb-0.1 and libusb-1.0 ?

If you need a link to then you most probably have to use libusb-1.0-0-dev

Revision history for this message
Mike Riley (mike-riley) said :

You may be correct. I just changed my script to link with and it works fine with that.

When I had looked for a package I think I searched for what had, not, and when that failed I tried and so ended up using libusb-dev as the package I installed.

Still, it seems like in that package should be a symbolic link to the right SONAME file, but I will leave that up to you to decide if it is an issue as this solves my problem by using

Revision history for this message
Mike Riley (mike-riley) said :

Thanks Manfred Hampl, that solved my question.