Libreoffice doesn't find the wifi printer, all other apps do.

Asked by jgkellt001 on 2019-06-12

I can't get LibreOffice 6.2.4 to find my Epson wf-2530 wifi printer. This has only happened since LibreOffice updated. All my other apps do find the printer. Settings - Devices - printers, doesn't find the above printer either.
I looked on the LibreOffice web site but couldn't find anything constructive. I have removed and reinstalled the app.
Any help will be appreciated, as I don't really want to export all my documents to PDF just to print them.
Thanks in anticipation;

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu libreoffice Edit question
Assignee:
No assignee Edit question
Solved by:
jgkellt001
Solved:
2019-06-13
Last query:
2019-06-13
Last reply:
2019-06-13
Tony Pursell (ajpursell) said : #1

You should be setting up the printer in Settings > Devices > printers for LibreOffice to find it.

Which version of Ubuntu are you running?

Try asking on Ask Ubuntu about setting up this printer.

It's needs a driver

See https://epson.com/Support/Printers/All-In-Ones/WorkForce-Series/Epson-WorkForce-WF-2530/s/SPT_C11CC37201?review-filter=Linux

Do other applications print OK?
What is the output of:

lsb_release -a; uname -a; lsusb

Thanks

Also what is the output of:

apt-cache policy libreoffice

Thanks

jgkellt001 (johnkelly01) said : #4

Other Apps all seem to print ok. The output requested is;
1)
LSB Version: core-10.2019031300ubuntu1-noarch:printing-10.2019031300ubuntu1-noarch:security-10.2019031300ubuntu1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 19.04
Release: 19.04
Codename: disco
Linux johngk-HP-Laptop-15-bw0xx 5.0.0-16-generic #17-Ubuntu SMP Wed May 15 10:52:21 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
Bus 001 Device 003: ID 8087:0aa7 Intel Corp.
Bus 001 Device 002: ID 0438:7900 Advanced Micro Devices, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 002: ID 05c8:03ac Cheng Uei Precision Industry Co., Ltd (Foxlink)
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
johngk@johngk-HP-Laptop-15-bw0xx:~$

2)
johngk@johngk-HP-Laptop-15-bw0xx:~$ apt-cache policy libreoffice
libreoffice:
  Installed: 1:6.2.4-0ubuntu0.19.04.1
  Candidate: 1:6.2.4-0ubuntu0.19.04.1
  Version table:
 *** 1:6.2.4-0ubuntu0.19.04.1 500
        500 http://gb.archive.ubuntu.com/ubuntu disco-updates/universe amd64 Packages
        100 /var/lib/dpkg/status
     1:6.2.2-0ubuntu2 500
        500 http://gb.archive.ubuntu.com/ubuntu disco/universe amd64 Packages

I have tried Settings to add my printer but it doesn't see it.
Regards JGKellt

If you close all Libreoffice applications, then rename the Libreoffice configuration folder which resides under ~/.config does it work OK when you run Libreoffice application again (You will get vanilla settings again)

Does this help?

jgkellt001 (johnkelly01) said : #6

Tony, I've already tried all of those options and no joy.

actionparsnip, tried the file rename but still no printer showing.

If you run libreoffice using sudo does it work OK?

jgkellt001 (johnkelly01) said : #8

Sudo LibreOffice launches but Print still doesn't find the printer. Ctrl P within LibreOffice still doesn't find the printer either.

Then it's not permissions. I suggest you post on the libreoffice forum as well. It's closer to your issue.

jgkellt001 (johnkelly01) said : #11

Andrew thanks for your efforts. I've just had another attempt at printing via LibreOffice and hey presto, it's finding my printer again. I have no idea as to what's happened, but the good news printing is up and running again. I had already looked up LibreOffice forums and could only find ancient issues. Perhaps there was a system update I didn't spot?? Anyway, Thanks again to Tony and Andrew for your assistance.