again libre office Base says JRE is corrupt

Asked by Cliffm on 2019-02-02

Hello
I had a similar problem last month that was solved Base was not installed.
things I have done this time.

Opened Libre office Base it says
Corrupt JRE
Removed JRE

sudo apt-get remove default-jre

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  default-jdk-headless libhsqldb1.8.0-java libservlet3.1-java
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  default-jdk default-jre
0 upgraded, 0 newly installed, 2 to remove and 12 not upgraded.
After this operation, 12.3 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 228053 files and directories currently installed.)
Removing default-jdk (2:1.10-63ubuntu1~02) ...
Removing default-jre (2:1.10-63ubuntu1~02) ...

java -version
java version "1.8.0_181"
Java(TM) SE Runtime Environment (build 8.0.5.22 - pxa6480sr5fp22-20180919_01(SR5 FP22))
IBM J9 VM (build 2.9, JRE 1.8.0 Linux amd64-64-Bit Compressed References 20180915_397057 (JIT enabled, AOT enabled)
OpenJ9 - 6c152c2
OMR - 15647c3
IBM - d734883)
JCL - 20180821_01 based on Oracle jdk8u181-b12

-------------------Base still says JRE is coruupt----------------------------

Removed Libreoffice using ubuntu software center
Re-Installed Libreoffice
restarted computer

-------------------Base still says JRE is coruupt---------------------------

lsb_release -a; uname -a; apt-cache policy libreoffice
LSB Version: core-9.20170808ubuntu1-noarch:printing-9.20170808ubuntu1-noarch:security-9.20170808ubuntu1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic
Linux Eagle 4.15.0-44-generic #47-Ubuntu SMP Mon Jan 14 11:26:59 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
libreoffice:
  Installed: (none)
  Candidate: 1:6.0.7-0ubuntu0.18.04.2
  Version table:
     1:6.0.7-0ubuntu0.18.04.2 500
        500 http://mirror.umd.edu/ubuntu bionic-updates/universe amd64 Packages
     1:6.0.3-0ubuntu1 500
        500 http://mirror.umd.edu/ubuntu bionic/universe amd64 Packages

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu libreoffice Edit question
Assignee:
No assignee Edit question
Solved by:
Cliffm
Solved:
2019-02-04
Last query:
2019-02-04
Last reply:
2019-02-04

If you rename the config folder for libreoffice, then run it is it OK?

Cliffm (c2mcatee) said : #2

change in .config libreoffice to libreoffice-2 No effect changed back to original
change snap/libreoffice to -3
      this caused snap to load new version libreoffice.
     deleted the snap/libreoffice-3
Picked Libreoffice/Basic and it loaded.
It seems to be working.
Thanks again actionparsip
Cliff