/usr/bin/soffice is or has a broken link

Asked by ealthuis on 2018-06-04

THe symlink for Libre Office claims it is broken, how to fix:

name:soffice

Link (broken) (inode/symlink)

../lib/libreoffice/program/soffice

34 bytes

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu libreoffice Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2018-06-05
Last query:
2018-06-05
Last reply:
2018-06-05
ealthuis (ealthuis) said : #1

I have tried to recreate the link, using "sudo ln -s ../lib/libreoffice/program/soffice soffice " while in /usr/bin,

this resulted in the link existing but it shows as above

Tony Pursell (ajpursell) said : #2

Have you go the correct permissions. I have:

Owner: root Access: Read and Write
Group: Root Access: Read-only
Others: Access: Read-only

Execute: Allow executing file as program

(This link was created by the installation)

Manfred Hampl (m-hampl) said : #3

As far as I know, the file /usr/bin/soffice should be a link to /usr/lib/libreoffice/program/soffice
and the latter should be a shell script.

For diagnostic purposes please provide the output of the commands

uname -a
lsb_release -crid
apt-cache policy libreoffice-common
ls -l /usr/bin/soffice
ls -l /usr/lib/libreoffice/program/soffice

ealthuis (ealthuis) said : #4

Answer to Tony Purcell:

Owner: root Access: Read and Write
Group: Root Access: Read-only
Others : Access:Read and Write

Execute: Allow executing file as program

ea@Discovery:~$ uname -a
Linux Discovery 4.4.0-127-generic #153-Ubuntu SMP Sat May 19 10:58:46 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
ea@Discovery:~$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 16.04.4 LTS
Release: 16.04
Codename: xenial
ea@Discovery:~$ apt-cache policy libreoffice-common
libreoffice-common:
  Installed: (none)
  Candidate: 1:5.4.6~rc2-0ubuntu0.16.04.1
  Version table:
     1:5.4.6~rc2-0ubuntu0.16.04.1 500
        500 http://ppa.launchpad.net/libreoffice/libreoffice-5-4/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/libreoffice/libreoffice-5-4/ubuntu xenial/main i386 Packages
        100 /var/lib/dpkg/status
     1:5.1.6~rc2-0ubuntu1~xenial3 500
        500 http://ca.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://ca.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages
     1:5.1.2-0ubuntu1 500
        500 http://ca.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
        500 http://ca.archive.ubuntu.com/ubuntu xenial/main i386 Packages
ea@Discovery:~$ ls -l /usr/bin/soffice
lrwxrwxrwx 1 root root 34 Jun 4 06:57 /usr/bin/soffice -> ../lib/libreoffice/program/soffice
ea@Discovery:~$ ls -l /usr/lib/libreoffice/program/soffice
ls: cannot access '/usr/lib/libreoffice/program/soffice': No such file or directory
ea@Discovery:~$

Manfred Hampl (m-hampl) said : #5

You seem to be missing the package libreoffice-common which cares for installation of the /usr/lib/libreoffice/program/soffice script.

How did you install LibreOffice, if you do not have the libreoffice-common package installed?

ealthuis (ealthuis) said : #6

Downloaded, then extracted to "Extracts, there CD to Libreoffice.. and then to Debs and installed with "sudo dpkg -i *.deb

Interestingly, this affects only my laptop that has Libreoffice 6.0.3.2, the latter installed with 18.04LTS.

The other desktops with v5 and 6.0.3.2 respectively do not appear to be affected.

So my simple solution seems to be to install Libreoffice 6.0.3.2 from the Ubuntu repository??

Manfred Hampl (m-hampl) said : #7

From which source do you download the deb files?
Why can't you use the package management system?

ealthuis (ealthuis) said : #8

CORRECTION; the statement "the latter installed with 18.04LTS" belongs on the subsequent line, "The other...etc"

ealthuis (ealthuis) said : #9

I believe I used the libreoffice ppa to download LO 6.

At the time when I did that the Ubuntu software did not have LO 6. I always want the newest, a bad habit I know but that is what I do, maybe not so smart...

One of my desktops, I use it for email mostly currently has ubuntu-unity7 18.04LTS and runs perfectly, no problems since I installed it on a new SSD.

Best Manfred Hampl (m-hampl) said : #10

Proposal for solution: install the package libreoffice-common in the version fitting to the other libreoffice packages on the affected system.

ealthuis (ealthuis) said : #11

Thanks Manfred Hampl, that solved my question.