Extra transparent menubar when started directly.

Asked by Krister Swenson on 2016-09-30

Starting libreoffice by opening an .odp file in Nautilus, or by starting Impress, Writer, etc. directly results in a white bar at the top. Clicking at different location of this bar opens the dropdown menus as if it were a menubar (it is a menubar without text).

This bar does not exist if Libreoffice is first opened, and then one of Impress, Writer, Calc, etc. are chosen.

I hesitate to post this as a bug with libreoffice since it probably has something to do with the way Unity deals with menus.
Does someone have advice on where to report this?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu libreoffice Edit question
Assignee:
No assignee Edit question
Solved by:
Krister Swenson
Solved:
Last query:
Last reply:

If you run:

ubuntu-bug libreoffice-impress

It will start the process

Krister Swenson (thekswenson) said : #2

I get the following popup for that command:

"""
The problem cannot be reported:
This is not an official Ubuntu package. Please remove any third party package and try again.
"""

Or use:

ubuntu-bug libreoffice

Bit more generic but should work

Krister Swenson (thekswenson) said : #4

This give the same error message.
Maybe this is another bug?

Krister Swenson (thekswenson) said : #5

I did at one point have multiple libreoffice packages installed but uninstalled all of them and then reinstalled libreoffice from the standard Xenial repository.

What is the output of:

apt-cache policy libreoffice

Thanks

Krister Swenson (thekswenson) said : #7

Thank you for the command.
I understand now that I'm using the libreoffice PPA which may be poorly integrated with unity.

"""
=> apt-cache policy libreoffice
libreoffice:
  Installed: 1:5.2.1~rc2-0ubuntu1~xenial0
  Candidate: 1:5.2.1~rc2-0ubuntu1~xenial0
  Version table:
 *** 1:5.2.1~rc2-0ubuntu1~xenial0 500
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status
     1:5.1.4-0ubuntu1 500
        500 http://mirrors.ircam.fr/pub/ubuntu/archive xenial-updates/universe amd64 Packages
        500 http://mirrors.ircam.fr/pub/ubuntu/archive xenial-security/universe amd64 Packages
     1:5.1.2-0ubuntu1 500
        500 http://mirrors.ircam.fr/pub/ubuntu/archive xenial/universe amd64 Packages
"""

Then you aren't using the version from the repository. Results cannot be guaranteed.

I suggest you contact the maintainer to report the issue.

Is there a specific feature you need in the newer version?

Krister Swenson (thekswenson) said : #9

Thanks for the advice.

There's a terrible bug that breaks slide animations in the 5.1 branch.