nfs-common /home share hangs can't login

Asked by Markus Herzog on 2013-08-21

Hi All,
My /home/user was on a nfs share ( Synology NAS ) and was working without any problems. After a Hardware Change, i installed Ubuntu 13.04 X64
( The old version was ubuntu 12.04 on 32bit System )
####################
uname -a
Linux big 3.8.0-29-generic #42-Ubuntu SMP Tue Aug 13 19:40:39 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
cat /etc/fstab
nas:/volume1/big/ /data nfs auto,rw,intr,hard,timeo=1 0 0
####################
i could never login. --> System hang

Then I login with a other users. The /home of this user was on local storage.
With the same mount options all works fine. No Locks, copy of TB without any Problems.
When i put the same "locked home" of my nfs-share user on the local storage, all was OK.

except libreoffice:

When i try to open a libreoffice file over the nfs share, the file was locked:
#####################
Die Dokumentdatei 'abrechnung_med3.ods' ist zum Bearbeiten gesperrt durch:

Unbekannter Anwender
#####################

Dr Google found a solution:
I comment/ uncomment the 4 Lines in

##################
vi /usr/lib/libreoffice/program/soffice
##################

#
STAR_PROFILE_LOCKING_DISABLED=1
export STAR_PROFILE_LOCKING_DISABLED
#

# file locking now enabled by default
#SAL_ENABLE_FILE_LOCKING=1 # <<- if set to 0 ; same trouble ...
#export SAL_ENABLE_FILE_LOCKING
#######################################

Now, no lock occured.
Can i configure the lockd, or did someone have a Idea ?
I like to have my /home on the nas ...

Thanks for help

Markus

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu libreoffice Edit question
Assignee:
No assignee Edit question
Solved by:
Markus Herzog
Solved:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

Change the fstab line from 'auto' to 'noauto'

You can then add this line in /etc/rc.local above the 'exit 0' line:

mount /home

The network comes up after fstab is processed, so if you have it as noauto, it will not be mounted at boot, but the line in rc.local will make it attempt to mount, and work as the LAN has had time to come up.

Is this what you mean or did I miss the point?

Thanks

Revision history for this message
Markus Herzog (kusi-herzog) said :
#2

Hi,
i try it with the entry in /etc/rc.local. Nothing changed.

But, now i found the solution:
Something has changed in the nfs-common or the lockd, between the old 12.04 - 32bit and my ubuntu version.
I mount my /home with the "nolock" mount option:
###############
cat /etc/fstab
nas:/volume1/big/ /data nfs auto,rw,intr,hard,timeo=1,nolock 0 0
###############
and it works!
Login, and open libreoffice files is successful with the default /usr/lib/libreoffice/program/soffice settings.
I'm the only user in my enviroment. So the locking mechanism is not so importend ... (?)
But in a multi user env, this could by a problem ...

Thanks