How do I get the right version of libudev1 dbgsym so that my crash report is not marked as invalid?

Asked by David Fraser on 2013-07-23

See https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1203985 and https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1203656

I'm on raring; opening certain .docx files crashes LibreOffice reliably. The automatic bug reports are marked as invalid, saying:

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate a useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

outdated debug symbol package for libudev1: package version 198-0ubuntu11.1 dbgsym version 198-0ubuntu11

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

apt-get dist-upgrade shows no new packages. apt-cache policy libudev1 shows:

libudev1:
  Installed: 198-0ubuntu11.1
  Candidate: 198-0ubuntu11.1
  Version table:
 *** 198-0ubuntu11.1 0
        500 http://za.archive.ubuntu.com/ubuntu/ raring-updates/main i386 Packages
        100 /var/lib/dpkg/status
     198-0ubuntu11 0
        500 http://za.archive.ubuntu.com/ubuntu/ raring/main i386 Packages

What do I need to upgrade? Or how else can I get this crash accepted as an issue?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu libreoffice Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
Last query:
Last reply:

Tried renaming the libreoffice configuration folder?

David Fraser (davidf) said : #2

Renaming the libreoffice configuration folder? What does that have to do with the version of debug symbols that I have installed? I don't think that relates to this at all

It will give you default libreoffice settings and may make the docx file open as normal....

Manfred Hampl (m-hampl) said : #4

One idea:
You could downgrade your libudev1 package to 198-0ubuntu11 with the hope, that this removes the dbgsym version difference.
(Caveats: you might need to downgrade also other systemd packages because of dependencies.
The developers might then refuse the bug report, claiming that you do not have the most up-to-date package versions).

David Fraser (davidf) said : #5

Right, you're trying to solve the problem of why it crashes. But I was actually asking how I get the crash report to be accepted as an Ubuntu bug. Tried your suggestion (got rid of .libreoffice), but no change

David Fraser (davidf) said : #6

Manfred, thanks for that - unfortunately apport won't let me report it like that:

What would you like to do? Your options are:
  S: Send report (17.7 MB)
  V: View report
  K: Keep report file for sending later or copying to somewhere else
  I: Cancel and ignore future crashes of this program version
  C: Cancel
Please choose (S/V/K/I/C): S

*** Problem in libreoffice-core

The problem cannot be reported:

You have some obsolete package versions installed. Please upgrade the following packages and check if the problem still occurs:

libudev1

Best Manfred Hampl (m-hampl) said : #7

That's what I was concerned about. Ok, not the developers, but even apport complained about an obsolete package version.

Maybe this is a potential workaround: Temporarily disable raring-updates as software source and do apt-get update. With that apport should forget that an updated libudev1 package is available. The question then of course is if apport accepts all other packages from raring-updates as legitimate or aborts with the message that they are no original packages any more.

David Fraser (davidf) said : #8

Thanks Manfred Hampl, that solved my question.

David Fraser (davidf) said : #9