Libre Office Data Base Files

Asked by srikumar on 2013-01-08

Ubuntu 12.10
Libre Office Version 3.6.2.2

I am unable to open my existing Data Base Files since upgrading to the latest Ubuntu 12.10.

The error message is as follows:-
The connection to the data source "My Data File" could not be established.
No Java installation could be found. Please check your installation.

More details: SQL Status :HY00

Is there any other program or add on that should be installed or any changes in the configuration?
The path statement under options has been correctly set.

any suggestions?

thank you
srikumar

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu libreoffice Edit question
Assignee:
No assignee Edit question
Solved by:
Tony Pursell
Solved:
Last query:
Last reply:
Revision history for this message
N1ck 7h0m4d4k15 (nicktux) said :
#1

It says something about java

"No Java installation could be found. Please check your installation."

So try to install an open source version..first .

sudo apt-get install openjdk7-jre

maybe is better

sudo apt-get install ubuntu-restricted-extras

or both.

Try it.

Thanks

Revision history for this message
srikumar (ssrikumar) said :
#2

"sudo apt-get install openjdk7-jre" returns the following message
unable to locate package

Revision history for this message
Tony Pursell (ajpursell) said :
#3

Go to the Ubuntu Software Centre and search for 'java'. You should see Java packages first on the list and you can install them from there.

Revision history for this message
srikumar (ssrikumar) said :
#4

The search indicates that the following are installed:-

OpenJDK Java 7 Runtime
OpenJDK Java 6 Runtime
OpenJDK Java 7 Policy Tool
OpenJDK Java 6 Policy Tool
IcedTea Java Web Start
IcedTea Web Control Panel

Is there any other program or add-on to be installed?

Thank you
srikumar

Revision history for this message
Best Tony Pursell (ajpursell) said :
#5

You need to check that LibreOffice is using one of the Java Runtimes. Go to Tools > Options... > LibreOffice > Java.

If there are entries for Java 6 Runtime and Java 7 Runtime shown, change the one selected and try again after closing and re-starting LO. Also check that the Location shown for the Runtime is correct.

You may find that you need to use Java 6 Runtime.

Revision history for this message
srikumar (ssrikumar) said :
#6

Thank you Tony

The fisrt para worked fine.

kind regards
srikumar

Revision history for this message
srikumar (ssrikumar) said :
#7

Thanks Tony Pursell, that solved my question.