in 12.04 message that /.config/libreoffice does not exist

Asked by athun on 2012-11-01

Using 32 bit 12.04, classic desktop no effects. When I upgraded from 10.04LTS using on-line update tool libreoffice stopped working. Present in 12.04 software center, synaptic, and applications menu but when I try to open file I get message: "This link cannot be used, because its target "../../lib/libreoffice/share/xdg/startcenter.desktop" doesn't exist." Reinstall does not help and if I try to rename /.config/libreoffice I get message /.config/libreoffice does not exist. Have tried updating using 2 different drives and 2 different board/cpu combinations, and file purge and reinstall, with same result. Any help appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu libreoffice Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
Last query:
Last reply:

Can you give the output of:

lsb_release -a; uname -a; apt-cache policy libreoffice

Thanks

athun (av908) said : #2

Sorry to take so long to respond. Here are outputs you requested. Thanks for help

uname -a:

Linux athun-ub1204 3.2.0-32-generic-pae #51-Ubuntu SMP Wed Sep 26 21:54:23 UTC 2012 i686 athlon i386 GNU/Linux

apt-cache policy libreoffice:

libreoffice:
  Installed: 1:3.5.4-0ubuntu1.1
  Candidate: 1:3.5.4-0ubuntu1.1
  Version table:
 *** 1:3.5.4-0ubuntu1.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
        500 http://security.ubuntu.com/ubuntu/ precise-security/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.5.2-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages

lsb_release -a:

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise

N1ck 7h0m4d4k15 (nicktux) said : #3

Try

~$ sudo apt-get remove --purge libreoffice*

and then

~$ sudo apt-get install libreoffice

Thanks

athun (av908) said : #4

As mentioned in my help request I have already tried to purge and reinstall. Doesn't work. Thanks for trying, though.

Additional information: If I try to purge I get message package cannot be removed because it isn't installed. If I try to reinstall using apt-get I get message package can not be installed because "Package libreoffice is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package libreoffice has no installation candidate:

athun (av908) said : #5

Decided to make a clean reinstall of 12.04, use classic desktop(no effects), and try to start Libreoffice after every action to see when it disappears. Turns out that I have no problem starting Libreoffice directly from the applications menu but if I place icons on the desktop those icons are not functional. The same appears to hold true for a number of other applications. Some will start from the installed desktop icons and some will not and will only start from the applications menu. Seems to me probable it is a bug. Has anyone else run into the same problem?

Best N1ck 7h0m4d4k15 (nicktux) said : #6

How you tried to place icons on the desktop ?
This probably is a matter of the environment (gnome-classic no effects).

1) If you want to create an icon in the bar (panel) then press "Alt+Super+right click" on the panel and you will see the options.

2) If you want to create a launcher , you have to use the gnome-desktop-item

~$ gnome-desktop-item-edit ~/.local/share/applications/ --create-new

if you want the libreoffice-writer , then at the command field write /usr/bin/libreoffice --writer

in the other fields write anything you want.
Also you can add your own picture / icon - just click at the "red missile" - like icon.

When the creation of the launcher finish , drag and drop the launcher at your desktop and it will work.

Thanks

athun (av908) said : #7

It works. Many thanks for your help.

athun (av908) said : #8

Thanks NikTh, that solved my question.