12:10/LibreOffice Trusted Sources

Asked by adam jvok on 2012-10-24

Fresh upgrade from 12.04 to 12.10. 64bit.

LibreOffice did not migrate the macro security trusted sources settings. Mildly irritating, but no big deal.

But then, try to add a new setting for trusted sources appears impossible - whatever directoy I select gets replaced with my home directory.

I tried:
exit libreoffice,
rm -rf ~/.config/libreoffice
start libreoffice.
try again.
Same result.

The only solution I can see is to edit .config/libreoffice/3/user/registrymodifications.xcu and manual change the value of SecureURL.

Any one else seeing this or am I doing something dumb?

Thanks for any advise.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu libreoffice Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:

Why are you using force, if the application is closed and the folder is owned by you?

adam jvok (ajvok1) said : #2

Not good reason. The '-f' was not necessary. Force of habit, I guess.
But I don't think its relevant to the problem.
I only deleted the config files as I had a vague idea that resetting to default values might cure the issue.
But it did not.
This seems to be a bug in LibreOffice.

Its a REALLY bad habit to get into. Throwing forces around when its simply not needed can easily break your OS. It's not relevant to the issue but by using it you can generate other issues later, then you will be posting back here when you screw up your OS.

I suggest you report a bug

Can you help with this problem?

Provide an answer of your own, or ask adam jvok for more information if necessary.

To post a message you must log in.