There's a glitch in LibreOffice in regards to page numbering

Asked by Tiffany

I am in the process of laying out a book and issues with page numbers have forced me to find a solution which involves paginating each chapter separately. The problem occurs when attempting to add page number to the second chapter which has to start on page 9. Offset numbering doesn't work at all for this purpose and so I attempted another fix which involved clicking into the document in front of the first paragraph and then following the steps found on a forum which are as follows:

Insert>Manual Break>page break>style:First page>change page number

I change the page number to 9 which is where I need it to start and it works but not as intended since it leaves a blank page. Deleting this blank page alters the page numbers, moving the text up to fill this page alters the page numbers and saving the file so that it can be inserted into another document causes the same issues.

I can't have random blank pages in this document and unfortunately I'm on a tight deadline.

Does anyone know another way to start the page numbers at a number other than 1 that's simple, I have eleven chapters I have to do this with and for some reason the simplest solution (numbering the entire document) doesn't work as the numbering abruptly stops around page 25.

It may matter so please note that I'm using a 6x9 template to place the text in.

Question information

English Edit question
Ubuntu libreoffice Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

If you suspect a bug I recommend you report one

Revision history for this message
Tiffany (cana646) said :

I've spent the better part of the morning looking for information on how to do this and whether or not it could be a bug and it's more likely that I'm doing something wrong or that the template I'm using (not one from Libre Office) is the source of the issue.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Just run:

ubuntu-bug libreoffice

And it will start the process.

Revision history for this message
Tiffany (cana646) said :

That doesn't help me, I have checked and rechecked and rechecked and my libreoffice is up to date and aside from opening it and allowing it to update I don't know how to check whether or not it's glitchy.

I've searched online and there are no known bugs related to page numbering and chances are really good that I'm missing a simple yet critical step somewhere as the numbering works just not as I intended it to.

Normally I'd ask my bf to fix this (he's the computer whiz not me) but that's not an option and I need a fix now.

Revision history for this message
Tony Pursell (ajpursell) said :


Have you tried

Insert > Manual Break... then select Page Break, select a Style, then enter a Page Break.

You do that immediately after the last thing on the previous page.

The latest LO version in Ubuntu 12.04 is what I am using. If you have that you will see a blue dotted line between the pages to signify the break, and if you hover on it with the mouse you get an icon to click to amend the Page Break properties.

Revision history for this message
Tiffany (cana646) said :

Three things:

1) Thank you for trying to help

2) There is no previous page. I'm numbering each chapter individually and saving the files since for some unknown reason I can't paginate the file that has all of the chapters in it properly (keep in mind that this is a file that's passed through several hands and so I'm not sure what the issue is with that or where it occurred and I've made peace with having to do this the hard way i.e. numbering each chapter separately and inserting them all into a single file).

3) I have no clue as to what the corresponding Ubuntu version is, I open Libre Office, it says Libre Office 3. I'm running Linux Mint 11 presently and really don't want to have to waste time swapping out my OS for something that should work across derivatives

Revision history for this message
Tiffany (cana646) said :

I figured it out, turns out offset pagination works just fine BUT you have to offset the first three page numbers before it'll catch properly.

Revision history for this message
Tony Pursell (ajpursell) said :

LO is what I have got, so probably quite close to yours. Help > About will tell you your exact version.

Here is what the Help says:

To Start With a Defined Page Number

Now you want some more control on page numbers. You are writing a text document that should start with page number 12.

1. Click into the first paragraph of your document.
2. Choose Format - Paragraph - Text flow.
3. In the Breaks area, enable Insert. Enable With Page Style just to be able to set the new Page number. Click OK.

The new page number is an attribute of the first paragraph of the page.

That's a bit terse, so here is a picture of what it should look like

If this doesn't work, then it must be a problem with the template you are using.

By the way, this is an Ubuntu help facility. There's no problem with a question on LO, but, in general, it's not a place to get support for Linux Mint. So if you were going to treat it as a bug, you can't do that here.

Revision history for this message
Tiffany (cana646) said :

I fixed my issue...and so we're clear I wasn't looking for support with Mint but rather with Libre Office since it should work the same way no matter which version of Linux I'm running however as the OS might have been an issue it was worth mentioning.