Writer ignores theme in Xubuntu 12.04 when file is opened from file manager.

Asked by John Law on 2012-09-08

I installed Xubuntu 12.04 then recreated ~/Documents with Deja-Dup.
(I have not entered my email details yet so this is written from the old Natty partition. Same machine, different partition.)

I am using LibreOffice installed from Xubuntu repository. My Xubuntu theme is changed to Clearlight, in 'appearance' and in 'window manager' either Sassandra or Clearlight. (That is light greys and blues.)

Expected behaviour:
In the new installation completely updated, Sept 5, I opened a new document from inside LibreOffice, and also reopened an old document transferred from Natty, from inside LibreOffice. The theme was completely correctly applied.

Aberrant behaviour:
However, if I found the document I wanted in Xubuntu file manager, *.odf, and double clicked to open in LibreOffice, the Clearlight theme was not working at all. The entire window frame and buttons looked like the default gtk colors, a tint of yellow ochre, all corners square, no shadows. Particularly noticeable is the area outside of "Print layout" was black instead of the theme grey.

Ok, so I do know it is not a fault with LibreOffice itself because the same behaviour occurs with gedit. It is just a compatibility issue around the change from gtk2 to gtk3.

Workaround is to open documents from inside LibreOffice.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu libreoffice Edit question
Assignee:
No assignee Edit question
Solved by:
John Law
Solved:
Last query:
Last reply:

Did you copy over your libre/openoffice config?

John Law (anoctoil) said : #2

I am quite sure I did NOT copy the LibreOffice config.
OpenOffice has never been on either system.
When I used Deja-Dup I excluded ~/user then set only the individual folders in ~/user to be backed up.
A single clean formatted partition for Xubuntu.

That was my way to deliberately exclude all dot files from the backup.

John Law (anoctoil) said : #3

The problem is parts of the theme are GTK2 and other parts are GTK3. Seems that very few of the themes have both adjusted to work together. Its spaghetti code beyond my ken.

I have decided not to pursue this.
So for me it is solved.

I wanted to retrieve emails from my deja dup backup the first few times was able to tranfer the inbox to libre office by opening the inbox doing a select all then copy and paste. Now if I open the inbox it goes straight into a transfer to libre office and transfers page of garbage. I have tried sending the inbox via email by opening it with thunderbird but only end up going round in circles with the same Inbox which I cannot open correctly. I am running on ubuntu 12.04 LTS. I have also had a series of unusual problems like the names of files becoming unreadable or missing. I am fairly new to ubuntu previously using SUSE 11.3 I am beginning to wonder if ubuntu is a very good version of linux..
Cheesed off,
 Colin.

Can anyone please help me.