libre office writer,calc etc. items will not open in Documents or desktop

Asked by jay on 2011-12-18

newbie to Ubuntu (oneric11.10) and Libre Office ( am on a 27G partition,hp pavillion9500,Windows7 laptop)

items created using Libre Office suite will not open when clicked on in Documents or Desktop

it looks like only an icon is being created.

Also, only the full Libre Office opens from Dash or Launch , no individual app ..writer,calc, etc will open

Question information

English Edit question
Ubuntu libreoffice Edit question
No assignee Edit question
Last query:
Last reply:

This question was reopened

Nathan Heafner (nathan1465-5) said : #1

to see if its an issue with the file being created, right click the text document you are creating and click open with other application, show all applications, and choose gedit. See if it opens the document.

Try opening and creating your document, and save it to your desktop as and ODT file type, then right click the new file and pick open with libreoffice. See if that works for you.

Tony Pursell (ajpursell) said : #2

Hi Jay

LO documents will not open in gedit (the text editor). Anyway, not in any readable form. You will only get a load of random characters. But if you do get this, it does mean you have something in the file, at least.

Best thing is to right click on the file, select Properties and have a look under the Open With tab. For an ODT file, it should show LibreOffice Writer as the Default Application, i.e the application that will open the file when you double click it.

If LibreOffice Writer is there, but not as the default application, you can highlight it and click Set As Default.

If LibreOffice Writer is not there, you can click 'Show other applications', browse for it and add it to the list.

If LibreOffice Writer is there as the default application, and double clicking (or right clicking and selecting Open with LibreOffice Writer) does not work, then we have more serious problem.


Nathan Heafner (nathan1465-5) said : #3

Good point, thanks for that correction Tony.

jay (auldbee) said : #4

Thanks Nathan and Tony,

did as you advised with document and Libre Office writer is set as default.
it makes a half-hearted effort to open writer ( bar goes about half way across...and writer fades out)

The same thing happens if i type Writer or Calc into the Dash.... bar starts and fades out.

To open Writer or Calc etc.. i can only open them from inside the Libre Office dashboard.

Tony Pursell (ajpursell) said : #5

Hi Jay

Try running LO from a terminal (Ctrl-Alt-T will bring up a terminal) with the command

libreoffice - - writer

or with a document

libreoffice - - writer something.odt

if you are skilled enough with the terminal to navigate to a folder with a document in it.

That will show if there are any error messages.

If there are, try and copy (see the Terminal's Edit menu) and paste them here.


marcus aurelius (adbiz) said : #6

Did you upgrade from a version prior to 11.04? I suspect the icon that's giving you problems is link to OpenOffice and was not removed when you upgraded. That happened to me and someone else when I installed 11.10.

jay (auldbee) said : #7

Hi Tony,

tried writer in terminal... like you posted and got this:

HP-Pavilion-dv9500-Notebook-PC:~$ libreoffice --writer

(soffice:1978): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(it tries and fails to open. ) Not skilled with terminal or linux or forums.

     no....only had Vista which i upgraded to Windows7 and ubuntu11.10 is from a Linux mag c/d

José Antonio Rey (jose) said : #8

Have you MD5 checked the .iso file, and burnt the CD as slow as possible?

jay (auldbee) said : #9


did not error check the c/d (Guilty)

MD 5 and slow burning .. i am totally in the dark about.

Nathan Heafner (nathan1465-5) said : #10

this is related to a prior suggestion by another user regarding md5's
MD5 is a way to verify data integrity.

When i run
libreoffice --writer

i too get the same error you do " Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap", though my libreoffice continues to load and works as normal.

Maybe you should open the Ubuntu Software center, search for libreoffice, uninstall writer, and then resinstall it.

Tony Pursell (ajpursell) said : #11

Probably best to *completely* remove LibreOffice. Best to do that in a terminal with this command

sudo apt-get purge libreoffice

enter your password when prompted.

This will remove all the LO software and configuration files, but not your documents.

Then re-install all of LO using Software Centre.

Can you help with this problem?

Provide an answer of your own, or ask jay for more information if necessary.

To post a message you must log in.