Not possible to Install LibreOffice (from ppa) in Maverick

Asked by Vish on 2011-02-28

Binary package hint: libreoffice

Similar to Bug #715144, but in maverick it is not possible to install LibreOffice.
 » http://paste.ubuntu.com/573459/
I tried after removing ure as mentioned in Bug 715144, but still same problem » http://paste.ubuntu.com/573469/

In addition to removing these:
openoffice.org-base-core (1:3.2.1-7ubuntu1.1)
openoffice.org-calc (1:3.2.1-7ubuntu1.1)
openoffice.org-common (1:3.2.1-7ubuntu1.1)
openoffice.org-core (1:3.2.1-7ubuntu1.1)
openoffice.org-draw (1:3.2.1-7ubuntu1.1)
openoffice.org-emailmerge (1:3.2.1-7ubuntu1.1)
openoffice.org-gnome (1:3.2.1-7ubuntu1.1)
openoffice.org-gtk (1:3.2.1-7ubuntu1.1)
openoffice.org-help-en-us (1:3.2.1-6ubuntu1)
openoffice.org-impress (1:3.2.1-7ubuntu1.1)
openoffice.org-math (1:3.2.1-7ubuntu1.1)
openoffice.org-style-human (1:3.2.1-7ubuntu1.1)
openoffice.org-writer (1:3.2.1-7ubuntu1.1)
python-uno (1:3.2.1-7ubuntu1.1)
ure (1.6.1+OOo3.2.1-7ubuntu1.1)

I'v also tried removing :
language-pack-en (1:10.10+20101204)
language-pack-en-base (1:10.10+20100930)
language-pack-gnome-en (1:10.10+20101204)
language-pack-gnome-en-base (1:10.10+20100930)
language-support-en (1:9.10+20090909)
language-support-writing-en (1:10.04+20100311)
libhyphen0 (2.5-1ubuntu1)
myspell-en-au (2.1-5)
myspell-en-gb (1:3.2.1-2ubuntu1)
myspell-en-za (1:3.2.1-2ubuntu1)
ttf-opensymbol (1:3.2.1-7ubuntu1.1)
uno-libs3 (1.6.1+OOo3.2.1-7ubuntu1.1)

But LibreOffice doesnt install, keeps giving broken packages

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu libreoffice Edit question
Assignee:
No assignee Edit question
Solved by:
Vish
Solved:
2011-03-01
Last query:
2011-03-01
Last reply:
2011-03-01
Fabián Rodríguez (magicfab) said : #1

I am converting this to a question as I couldn't reproduce in Ubuntu 10.10 23 or 64 bit.

Please don't use pastebin, its very nature means your information posted there may be lost.

In my test I removed all openoffice* packages found by a search on "openoffice", and also these: python-uno uno-libs3 ure ttf-opensymbol. However this is done automatically when using a package manager and installing LibreOffice as indicated here:
https://wiki.ubuntu.com/LibreOffice

Could you indicated exactly what steps you followed ? Thank you.

Vish (vish) said : #2

Gah! I had forgotten I have apt pinning in place..! :/
I had to following in my /etc/apt/preferences, Hence the broken packages..

Package: *
Pin: release a=maverick-security
Pin-Priority: 900

Package: *
Pin: release a=maverick-updates
Pin-Priority: 900

Package: *
Pin: release o=Ubuntu
Pin-Priority: 600

Package: *
Pin: release o=LP-PPA-xorg-edgers
Pin-Priority: 300

Package: *
Pin: release o=LP-PPA-ubuntu-mozilla-daily
Pin-Priority: 400

Package: *
Pin: release a=maverick-proposed
Pin-Priority: 400

And seeing that there is a Lucid bug for this, just thought it was a packaging error. Thanks for checking this issue.