Pacemaker 1.1.18 and Corosync 2.4.4 on Ubuntu 14.04

Asked by Salvatore D'Angelo on 2018-06-28

Hi all,

I would like to know if it is possible, in some way, have Ubuntu packages to install pacemaker 1.1.18 and corosync 2.4.4 on Ubuntu 14.04. I notice packages have been built only for Ubuntu 18.

I tried to install them from source but I had lot of issue with libqb with problems on /dev/shm.

Any suggestion?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu libqb Edit question
Assignee:
No assignee Edit question
Last query:
2018-06-28
Last reply:
2018-06-28

https://launchpad.net/ubuntu/+ppas?name_filter=pacemaker

https://launchpad.net/ubuntu/+ppas?name_filter=corosync

Maybe there is a PPA. Have you checked the project website too. They may have their own repository.

Manfred Hampl (m-hampl) said : #2

If I look at the dependencies of pacemaker 1.1.18-0ubuntu1 (in bionic), I see a dependency on libqb0 (>= 0.17.1)
Ubuntu 14.04 has libqb version 0.16

So I assume a prerequisite for pacemaker 1.1.18 on Ubuntu 14.04 is backporting libqb 0.17.1 (or higher) to that version.
There is a PPA https://launchpad.net/~mariosplivalo/+archive/ubuntu/corosync that might help with that.

Similar to the above you have to make sure that all requirements are met (and there are several of them).

Why Ubuntu 14.04, can't you upgrade to 16.04 or 18.04?

Can you help with this problem?

Provide an answer of your own, or ask Salvatore D'Angelo for more information if necessary.

To post a message you must log in.