sasl not work in libpam-ldap

Asked by liz

Hi all,

I'm trying to use pam-ldap to authenticate against active directory.
It works using simple bind. But could not config pam-ldap to use SASL authentication.
In "/etc/ldap.conf" I put "pam_sasl_mech DIGEST-MD5" but it still doing simple bind (everything in clear text).

And another silly question. Why I cannot extract the libpam-ldap hardy source package by "tar -zxvf libpam-ldap_184.orig.tar.gz"?
I've tried "chmod 777 ...", using window archive and also have verified md5 checksum.

Any help would be appreciated.



Question information

English Edit question
Ubuntu libnss-ldap Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
peter b (b1pete) said :

liz, did you try installing libpam-ldap package through synaptic ? it is much better/recommended to use the repositories of your distro than compiling the the source files.

if you still want to install the tar file then create a folder under /home , move/copy the tar file into that folder , right click on it and select Extract here option - the contents of the tar file will be extracted there.

hope this helps.

peter b

Revision history for this message
liz (seekstar) said :

peter, yes I did installed it through synaptic. It 's got the sasl problem therefore I am trying to compile the source myself.

You method of extracting the tar file does work. After I clicked "extract to", the windows archive application popped up a dialog window saying "Extracting ..." and just hangs here never terminates.

Thanks for your reply anyway.


Revision history for this message
peter b (b1pete) said :

liz, I do not have a clue why the extraction never completes.

I'd suggest to completely uninstall through synaptic libpam-ldap and the other dependencies that come with it namely


reboot the pc then install


hope it helps.

peter b

Can you help with this problem?

Provide an answer of your own, or ask liz for more information if necessary.

To post a message you must log in.