Locked out at password because I made a mistake when trying to get fingerprint activated.

Asked by Tony

This is the first time I've asked a question on any forum (as a Linux user for around 6 years) - I've always found (with great appreciation) answers that worked, but now I have a problem I can't find an answer for (so) ...

I have an old ThinkPad T42 - which was mine and is now my wife's much loved machine. I've had it running fine on Ubuntu 11.04 (for a few months) ... until ... I tried to get the 'fingerprint devise' activated (big mistake ... my wife probably wouldn't have used it anyway). I was following instructions I found to activate the devise using 'fprint'. I was working in the terminal. I was using sudo (and) root. I failed to get it working, so I gave up thinking "No worries ... I don't need it anyway".

When I restarted the machine a) up comes the login / (I hit enter) .... b) up comes a larger window than normal that shows the user (my wife's name) and the Password field (with the normal courser flashing ready to have the password entered.
BUT ALSO: Under the Password field is a line of copy I have never seen before which reads:
"Could not locate any suitable fingerprints matched with available hardware."
When I enter the machines password (and click enter to login) the window fades a little (as normal - as though it's checking the password before continuing to open) but then just comes back with the password field empty and I can't get in (time and time again).

My wife has a document in her home file that must be recovered! (all other files in this machine have been backed up)

I've tried:
To boot from grub with various options (ie as root) but I still can't get in.

Question (s):
1) Can anyone direct me to a solution to this problem that I've failed to find? (or)
2) Does anyone know how to solve this problem? (or)
3) Can I do a re-install of say Ubuntu 11.04 ... and get to change the password AND save existing files in the process?
4) Other?

I hope this isn't too much (or too little) detail.

Thanks for reading ... and thank you in anticipation.


Question information

English Edit question
Ubuntu libfprint Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
mycae (mycae) said :

Not sure about the fingerprint setup -- I don't really use those (low security). However, to recover your file:

boot to a liveCD, then use sudo nautilus to create a root file browser session.

Mount the partition containing the file you need to recover, and then copy


Remember that you *must* copy the file to somewhere outside the live session (onto a network storage device, a USB key, or burn a CD using a second drive -- whatever you can). The liveCD creates a RAM session, so when you reboot your computer, all data stored in RAM created during the live session will be lost.

Revision history for this message
Eliah Kagan (degeneracypressure) said :

First, you should recover the important document.

Boot the machine from an Ubuntu live CD/DVD or live USB flash drive (burned or written from the Ubuntu desktop install CD). Select Try Ubuntu rather than Install Ubuntu. When you get to the desktop, in the file browser (Nautilus), find and mount the hard disk for the installed Ubuntu system and recover the file. If you need more detailed help with this, please feel free to post a reply requesting it.

If your wife's home directory is encrypted, then you can still recover it as above (it is encrypted with her password, which presumably she knows, and not with her fingerprint). However, I am guessing that is not the case, so for the sake of expediency I'll wait to provide instructions for that until you indicate that they are needed.

After you've done that, please post here and let us know what instructions you followed for setting up the fingerprint device. Presumably they are online somewhere and we could look at them.

Revision history for this message
Sam_ (and-sam) said :

Verify permissions of ~/.ICEauthority and ~/.Xauthority.
Should belong to user with 600.
Or rename .Xauthority, reboot and try again.
You can also chown and chmod ~/home to <user> again.

Since playing with root, just in case verify sudoers.

Recovering files can also be done via live medium.
New pw can be created via recovery mode, I'd prefer reboot rather init 2.

Revision history for this message
Tony (bevear) said :

Thank you very much for the three, well written answers that I received almost immediately.
I have read the links that you have supplied. A lot of it was out of my depth, but it made enough sense.
I'm delighted to say that I'm sending this email from the machine that I couldn't get into this morning!
I downloaded an iso file of Ubuntu 11.10 (from the Ubuntu download page) and burnt a live CD.
I Booted the machine from the Ubuntu live CD.
I have selected Try Ubuntu (rather than Install Ubuntu) - and went to the desktop.
I opened the Home file and selected the (hard drive) file, listed under Devises, at the top of the left hand column of the window. I then opened the Home file (in amongst other files such as 'bin', 'boot', 'lib', 'usr') and there was the important file I wanted. I then got online (activated wireless, by clicking the icon, up in the panel and entering wep password), opened the browser and emailed the file to myself.
I then connected a (USB) externad drive and copied all the files in the Home folder.
Then I opened Ubuntu Software Center and un-installed fprint.
I then shutdown the machine and ejected the live CD - (with a paper-clip thru the little hole in the CD drive).
I then re-booted the machine normally and Voila ... Everything is perfect.
Thank you so much for your help and for saving my marriage ;)

Revision history for this message
Sam_ (and-sam) said :

Congratulation, very well done and thanks for describing the workaround.
Please mark question as solved too. Thanks.

Revision history for this message
Tony (bevear) said :

Thank you for the support.