./configure doesn't work properly

Asked by Jose Mendez on 2014-02-17

I did: bzr branch lp:libdbusmenu and had no problem.

but I tried to execute: ./configure and it starts working until I get this message:

---------------------------------------------------------------------------------------------------------------------------
         configure: error: Package requirements (glib-2.0 >= 2.35.4 -
                                          gio-2.0 >= 2.35.4) were not met: -

         Requested 'glib-2.0 >= 2.35.4' but version of GLib is 2.32.4 -
        Requested 'gio-2.0 >= 2.35.4' but version of GIO is 2.32.4 -

        Consider adjusting the PKG_CONFIG_PATH environment variable if you -
        installed software in a non-standard prefix. -

       Alternatively, you may set the environment variables DBUSMENUGLIB_CFLAGS -
       and DBUSMENUGLIB_LIBS to avoid the need to call pkg-config. -
        See the pkg-config man page for more details. -
---------------------------------------------------------------------------------------------------------------------------

Not only with configure but autogen.sh ... the same error

I have done: (with no problem)

sudo apt-get install pkg-config
sudo apt-get install build-essential
sudo apt-get install gnome-core-devel build-essential

echo $PKG_CONFIG_PATH
/usr/lib/pkgconfig

UBUNTU 12,04

Any help??????

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu libdbusmenu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2014-02-18
Last query:
2014-02-18
Last reply:
2014-02-18

You'll need the -dev packages of the named packages so that you can build what you need.

Jose Mendez (lomen30) said : #2

Thanks for you quick answer.

I have installed ok the next packages:

* libpackagekit-glib2-dev

* libgio-cil

* libgio2.0-cil-dev

* libghc-gio-dev

* libghc6-gio-dev

But to no avail. I mean the result is the same.

*******

I have also tried to install the next package just in case:

pepe@pepe-HP-Mini-110-4100:~/libdbusmenu$ sudo apt-get install libspice-client-glib-2.0-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 libspice-client-glib-2.0-dev : Depends: libspice-client-glib-2.0-1 (= 0.9-0ubuntu1) but it is not going to be installed
                                Depends: gir1.2-spice-client-glib-2.0 (= 0.9-0ubuntu1) but it is not going to be installed
                                Depends: libspice-server-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
pepe@pepe-HP-Mini-110-4100:~/libdbusmenu$

And thais the result . Maybe it can be useful for you.

Thanks..

Jose Mendez (lomen30) said : #3

This is the whole message I get after ./configure :

pepe@pepe-HP-Mini-110-4100:~/libdbusmenu$ ./configure
checking for a BSD-compatible install... /usr/local/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /usr/local/bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking whether NLS is requested... yes
checking for style of include used by make... GNU
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for intltool >= 0.35.0... 0.50.2 found
checking for intltool-update... /usr/bin/intltool-update
checking for intltool-merge... /usr/bin/intltool-merge
checking for intltool-extract... /usr/bin/intltool-extract
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/msgfmt
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.14.2
checking for XML::Parser... ok
checking for library containing strerror... none required
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking whether gcc and cc understand -c and -o together... yes
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking how to print strings... printf
checking for a sed that does not truncate output... /bin/sed
checking for fgrep... /bin/grep -F
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking how to convert i686-pc-linux-gnu file names to i686-pc-linux-gnu format... func_convert_file_noop
checking how to convert i686-pc-linux-gnu file names to toolchain format... func_convert_file_noop
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for dlltool... no
checking how to associate runtime and link libraries... printf %s\n
checking for ar... ar
checking for archiver @FILE support... @
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for sysroot... no
checking for mt... mt
checking if mt is a manifest tool... no
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking whether make supports nested variables... yes
checking for glib-mkenums... /usr/bin/glib-mkenums
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for gtkdoc-check... /usr/bin/gtkdoc-check
checking for gtkdoc-rebase... /usr/bin/gtkdoc-rebase
checking for gtkdoc-mkpdf... /usr/bin/gtkdoc-mkpdf
checking whether to build gtk-doc documentation... no
checking for DBUSMENUGLIB... no
configure: error: Package requirements (glib-2.0 >= 2.35.4
                                gio-2.0 >= 2.35.4) were not met:

Requested 'glib-2.0 >= 2.35.4' but version of GLib is 2.32.4
Requested 'gio-2.0 >= 2.35.4' but version of GIO is 2.32.4

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables DBUSMENUGLIB_CFLAGS
and DBUSMENUGLIB_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
pepe@pepe-HP-Mini-110-4100:~/libdbusmenu$

********************************************************************************
********************************************************************************

Best Manfred Hampl (m-hampl) said : #4

It seems that there are dependency problems for the trusty version of libdbusmenu that are not fulfilled in Ubuntu precise.

As you can see from https://launchpad.net/ubuntu/+source/glib2.0 the condition glib >= 2.35.4 requires the versions for saucy or newer.

So the prerequisites are not met.

I see the following possible options:
1. upgrade your system from precise to saucy or higher
2. go back to an older version of libdbusmenu (e.g. lp:ubuntu/precise/libdbusmenu )
3. try getting a sufficiently high version of glib and gio on your precise system (if that is possible at all; either from a PPA or by compiling from source).

Jose Mendez (lomen30) said : #5

Thanks Manfred Hampl, that solved my question.