GTX 480 Ubuntu 18.04 Lts not working

Asked by gip on 2018-12-09

Hi,

On my HP XW8600 I have the Nividia gtx 480 that worked great with 16.04 Lts

I did the upgrade to get to 18.04 and had a brief display and then a black screen with the non blinking cursor left top of the screen. Ubuntu default driver does not work either. I tried the 390 and 340 set with no luck.

This card is old but is still working fine. Corel Aftershot 3 loves it.

Rob

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu libclc Edit question
Assignee:
No assignee Edit question
Last query:
2018-12-10
Last reply:
2018-12-10

Did you install the proprietary video drivers ?

gip (gipukan) said : #2

Hello, yes I installed them from a ppa the 390 and 340 versions

Now I'm running a amd graphic card but I would love to use the gtx 480 again. Or would you suggest m,e to get a more dated card.

Rob

Proprietary video drivers rarely survive changes in release. Remove the Nvidia drivers and the PPA then reboot. You will then use the nouveau driver.

Once this is OK, reinstall the Nvidia driver (if you need it) and it should help

gip (gipukan) said : #4

I can give that an other try but even with the nouveau driver the screen is not good from what I remember.

Can you help with this problem?

Provide an answer of your own, or ask gip for more information if necessary.

To post a message you must log in.