Gtk-Message: Failed to load module "canberra-gtk-module"

Asked by Alfas on 2012-01-10

I am using Ubuntu 11.10 lxde, for all applications (for example leafpad) I get the same error message:
Gtk-Message: Failed to load module "canberra-gtk-module"

I search internet for sollution, but found only many complains and bug repports (none active) and no solution. Any ideas?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu libcanberra Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-01-20
Last query:
2012-01-20
Last reply:
2012-01-10
Alfas (alfonsasstonis) said : #2

Setting GTK_PATH makes no difference.

Alfas (alfonsasstonis) said : #3

To my surprise installing again libcanberra helped. Even if there was some version of it installed.
sudo apt-get install libcanberra-gtk-module

Alfas (alfonsasstonis) said : #4

Thanks actionparsnip, that solved my question.

jishaashok (jishaashok) said : #5

Reinstalling libcanberra-gtk-module helped. Thanks a lot!