Major dependency problems while installing libav-tools / ffmpeg / libavcodec55

Asked by A. Eibach on 2013-12-03

Hello,

although the codec system is perfect on Saucy and actually does not require ffmpeg at all, the thing is, once you start converting videos or ripping audio from video, you DO require ffmpeg.

Unfortunately, here on Saucy dependencies do not match AT ALL currently. And even though I could fix things by installing "unstable" packages using dpkg, I think putting up this question will also help others accomplish things OOTB.

Let's start:

- ffmpeg dependencies are:
(1) libavcodec55
(2) libavdevice55
(3) libavfilter3
(4)libavformat55

(1) libavcodec55
Sub-dependencies are:
a) libopus0 (>= 1.1~beta) -- CAN'T DO -- Latest on saucy is 1.0.1-0ubuntu2
b) libva1 (> 1.2.0~) -- CAN'T DO -- Latest on saucy is 1.1.1-3

(3) libavfilter3
Sub-dependencies are:
a) libavcodec55 (>= 10:2.1.1) -- CYCLIC DEP. see (1) --
b) libavformat55 (>= 10:2.1.1) -- CYCLIC DEP. see (4) --
c) libfontconfig1 (>= 2.11) -- CAN'T DO -- Latest on saucy is 2.10.93-0ubuntu1

(2) libavdevice55 + (4) libavformat55
Sub-dependencies are all cyclic and have already been mentioned.

This is all very awkward. Too high version numbers required by the install system are bringing things to a full halt.
I think if aptitude demanded a previous version of some of (1) to (4), things would work OOTB. However, currently all seems messed up.

How did you guys solve this problem *without* applying ugly DIY kludges like risking to make your system unstable by installing unsupported packages that do met deps? (I'd rather refrain from doing that)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu libav Edit question
Assignee:
No assignee Edit question
Solved by:
A. Eibach
Solved:
Last query:
Last reply:
Thomas Kr├╝ger (thkrueger) said : #1

The dependencies you are writing are not matching the dependencies on my system. What is the output of
lsb_release -a; apt-cache policy ffmpeg libav.+5.
?

Also, what is the output of:

lsb_release -a; apt-cache policy libavfilter3

Thanks

A. Eibach (andi3) said : #3

andy@andy-lubuntubox:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 13.10
Release: 13.10
Codename: saucy

WAIT A MOMENT...

No need to put my full apt-cache listing...

LOOK AT THIS

ffmpeg:
  Installed: (none)
  Candidate: 10:2.1.1-dmo1
  Version table:
     10:2.1.1-dmo1 0
        500 http://www.deb-multimedia.org/ sid/main i386 Packages
     6:0.8.9-0ubuntu0.13.10.1 0
        500 http://de.archive.ubuntu.com/ubuntu/ saucy-updates/main i386 Packages
        500 http://de.archive.ubuntu.com/ubuntu/ saucy-security/main i386 Packages
     6:0.8.7-1ubuntu2 0
        500 http://de.archive.ubuntu.com/ubuntu/ saucy/main i386 Packages
...

STOP. Uh-oh. And THAT solved the problem. I have to remove the deb-multimedia.org stuff from /etc/apt/sources.list at once. It is topmost in hierarchy, so that's why aptitude picks it at first. However, I first had to get the idea of doing 'apt-cache policy...'. Very sneaky. Thank you.

Installation works a treat now. Sometimes it's just a nudge you need to think in the right direction.

Yes you are mixing Debian packages which WILL cause problems

A. Eibach (andi3) said : #5

Not any more. But I WAS, yes. DMO was especially useful to apt-get me some ancient Win32 codecs which were essential to convert things from old to new.
But that should now be a thing of the past, since medibuntu too is a thing of the past.