Is ffmpeg supposed to be accessing gnome-keyring?

Asked by Mind Builder on 2013-05-28

I was using ffmpeg to trim a video and it worked, but every time I run it the top of the terminal output starts with the error:

"WARNING: gnome-keyring:: couldn't connect to: /run/user/mindbuilder/keyring-jAd74z/pkcs11: No such file or directory"

Does ffmpeg normally access the gnome-keyring or has my ffmpeg been trojaned to steal my encryption keys or something? It's not obvious why trimming a video would require access to my keyring.

I'm using ffmpeg version 0.8.6-6:0.8.6-0ubuntu0.12.10.1 under xubuntu 12.10 amd64.
I guess Xubuntu uses the Xfce desktop without gnome and so may not have gnome-keyring installed completely or even partially.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu libav Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
N1ck 7h0m4d4k15 (nicktux) said : #1

This probably is a bug or something like this. No, the ffmpeg is not hijacked. I don't think that you even need the gnome-keyring if you use XCFE desktop. You could disable gnome-keyring completely from start up applications.

Here is a fix for your specific problem: http://hongouru.blogspot.com.ar/2012/07/solved-warning-gnome-keyring-couldnt.html
replace LXDE with XFCE.

Regards
 NikTh

Can you help with this problem?

Provide an answer of your own, or ask Mind Builder for more information if necessary.

To post a message you must log in.