mod_dav writing files with umask 077 not 002

Asked by Salik Rafiq

Hello I am using Ubuntu 10.04 LTS and have setup my Apache server with mod_dav.
I have three folders which are shared both with internal users via Samba and external users via webdav.

Previously I was using Lighttpd and that worked wonderfully, except that I also had to use Apache for SVN access. So I consolidated down to Apache.

I created mounts to the shared folders in /var/www/webdav using --bind facility. I found out by trial and googling that Apache mod_dav does not follow symlinks. :(

Now my users have issues where files uploaded via webdav are not accessible by internal users. the files are created with rw-------+ permissions. I and using ACLS and that was the first thing I checked..they are fine.

I added the umask 007 into /etc/apache2/envvars - but that didn't work
I then added the pam_umask into the common-session and then did a chfn -o "umask=007" www-data and that also had no effect.

There is either a setting I have missed or this is a bug.

I now have to decide between putting lighttpd back on or using a script every few minutes to reset the file mask.

Question information

English Edit question
Ubuntu libapache-mod-dav Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Salik Rafiq (salik-rafiq) said :

I'm wondering really if the fix mentioned in the linked bug will make it into Lucid? The other question if I can do what I want in 10.10. I'm not really interested in this server runs the network (DHCP, DNS, Samba PDC, SVN, WEBDAV, APACHE, EMAIL, NAS) and would bring work to a halt if something went wrong.

I have seen fsniper and wonder if that is the way I need to go.

Can you help with this problem?

Provide an answer of your own, or ask Salik Rafiq for more information if necessary.

To post a message you must log in.