Where is the python3-ldb

Asked by Golanguage on 2017-04-13

The pyldb has been ported to python 3.
But why did python3-ldb be dropped?
python-ldb depends on python2.7 only

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ldb Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2017-04-13
Last query:
2017-04-13
Last reply:
2017-04-13
Best Manfred Hampl (m-hampl) said : #2

snippet from the change log:

2:1.1.26-1ubuntu3

Superseded in yakkety-release on 2016-09-28
Deleted in yakkety-proposed on 2016-09-29 (Reason: moved to release)

ldb (2:1.1.26-1ubuntu3) yakkety; urgency=medium

  * Drop python3 packages again. No reverse dependencies, and
    python3-talloc-dev is NBS.

 -- Martin Pitt <email address hidden> Wed, 07 Sep 2016 08:43:24 +0200

Available diffs
diff from 2:1.1.26-1ubuntu2 to 2:1.1.26-1ubuntu3 (1.8 KiB)

Golanguage (golanguage) said : #3

Does NBS stand for "Not Built from Source"?OK
.
But May this means samba will depend python2 forever.

Golanguage (golanguage) said : #4

Thanks Manfred Hampl, that solved my question.