The buttons that I try to rearrange in the launcher do not drag off launcher to put back on in a different order and when dragging they only drag up and down along the launcher, not outside of it.

Asked by Devin

I couldn't figure out how to rearrange the launcher items. So, I looked up how in Ubuntu documentation. I'm using 11.10 version of Ubuntu with Unity where I can't get the launcher to work. The documentation states that in order to rearrange the launcher button or item into a different order among them one must press and hold the button to click on the one you want to rearrange. Then, drag it off the launcher and back on in the desired position. The problem is, my widgets don't drag off the launcher and when I drag them, they only respond with just the abiblity to slide along the launcher, which is again not off the launcher like I have to in order to rearrange the widgets as I'd like.

I'd like to place Libre Office Draw in between Calc and Impress. But, it just goes to the bottom, above Workspaces. Any new shortcut on the launcher goes just above the Workspaces one. Rearranging it eludes me. When I try to drag one of the launcher shortcut buttons off the launcher, only the mouse cursor goes, and the application shortcut does not follow. I can't even get to the point to put the one I want to rearrange into the correct place, because the one I want to move, moves in unison with the rest. So, I think my clicker clicks all of them when I only see that I'm clicking one of them. They all drag together up and down along the launcher, not off, not in a different order.

If you need a screen shot I could take one. This problem may have to do with my graphics driver. It is new since Ubuntu 11.10 came out and the one available before it didn't support Unity and had an odd screen glitch. I can point you to the bug I filed for it a long time ago, before I came back to the Ubuntu distribution and found a new driver fixed that bug. I thought I'd post this bug as a question first. Perhaps, you know of a different way to reorganize the launcher than the documentation mentioned? If not, I thought someone would tell me whether this is a bug or not before I file one for it.

Question information

English Edit question
Ubuntu launcher Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Chris (fabricator4) said :

My first thought is that you are running Unity2D, not Unity3D. One of the main reasons for this is if you have not installed a graphics driver with 3D capability yet, or if 2D was previously running because of this reason and you haven't enabled Unity3D after a Graphics card and driver upgrade.

Have look at what modules are running - if you can't find compiz but can find modules Unity-2d-panel and Unity-2d-launcher then you are running Unity2D


Revision history for this message
Devin (8basepairs) said :

I'm pretty sure I'm using 3D Unity, because my desktop now, with my most recent installation of 11.10, looks like the pretty screen shots of Ubuntu 11.10 and my log in manager has the 3D Unity selected. So, on my first attempt to use 11.10 when it was first released I could only access 2D. For it did not have the driver that is available now. At about that release date I switched to Arch Linux because of various bugs from the the lack of a proper driver. But, that is not the issue.

I did a clean install of Ubuntu 11.10 most recently. Although the installation GUI still has the bugs, perhaps because the drivers load at the first boot up after installation, I did not have a problem like I did before like the lack of 3D support, which caused me to switch to Arch Linux for a while, but as soon as I booted up after the new fresh install of the Ubuntu 11.10 operating system the bug was gone.

I failed to mention that there was another driver in Additional Drivers called "NVIDIA accelerated graphics driver post-release updates (version 96-updates)," which failed to Activate when I installed Ubuntu 11.10 this time (i.e. a few days ago). I tried again today to tell you what error message the failure gave, but this time it worked. I rebooted after it the update-driver installed and now I can rearrange the icons in the Unity 3D Launcher :D !

The only issue now is that the instructions on the Ubuntu documentation are a little off, though I figured it out anyway, once I was able to with the post-release driver. Instead of drag the icon off the launcher and then back on in the order of your liking, I had to hold down the icon without moving my cursor for about a second. Then rearrange the icon WITHOUT taking it off the launcher or else it would do nothing. Now, the only way for me to move all the icons as one unit like this question was made to get around, is to move the mouse along the launcher as soon as I press the icon without a delay of about a second.

So, I suggest to people with this problem to wait after some more reboots, maybe with some updates, before trying to install an Additional Driver if it didn't work the first time after installation or so forth. Thank you for your willingness to help, Chris :) , problem solved.

Revision history for this message
Devin (8basepairs) said :

As I said, the bug with Unity 2D is separate from this question. This question has always been delt with Unity 3D. It was a problem with the non-updated driver for Unity 3D. Once one switches to the driver-updates that is also for Unity 3D, this question and problem is fixed. Therefore, I will change this issue back for Unity 3D, since someone changed it to 2D after the question was solved.