ubuntu 11.10 language settings window crashes when Ukrainian language installed

Asked by soulcor on 2012-01-01

Hi all,

I have a problem with the language window settings. This window opens when Ukrainian language is not installed.
Language settings throws the following exception and then closes with Ukrainian language installed.

--------------------------

admin1@admin1-Z68M-D2H:~$ sudo language-selector
[sudo] password for admin1:
sudo: language-selector: command not found
admin1@admin1-Z68M-D2H:~$ sudo gnome-language-selector

(gnome-language-selector:2626): Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed

(gnome-language-selector:2626): Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed

(gnome-language-selector:2626): Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed

(gnome-language-selector:2626): Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed

(gnome-language-selector:2626): Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed

(gnome-language-selector:2626): Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed
Traceback (most recent call last):
  File "/usr/bin/gnome-language-selector", line 27, in <module>
    options=options)
  File "/usr/lib/python2.7/dist-packages/LanguageSelector/gtk/GtkLanguageSelector.py", line 192, in __init__
    self.updateLocaleChooserCombo()
  File "/usr/lib/python2.7/dist-packages/LanguageSelector/gtk/GtkLanguageSelector.py", line 57, in wrapper
    res = f(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/LanguageSelector/gtk/GtkLanguageSelector.py", line 853, in updateLocaleChooserCombo
    self.updateExampleBox()
  File "/usr/lib/python2.7/dist-packages/LanguageSelector/gtk/GtkLanguageSelector.py", line 926, in updateExampleBox
    locale.setlocale(locale.LC_ALL, mylocale)
  File "/usr/lib/python2.7/locale.py", line 539, in setlocale
    locale = normalize(_build_localename(locale))
  File "/usr/lib/python2.7/locale.py", line 447, in _build_localename
    language, encoding = localetuple
ValueError: too many values to unpack

Could you please help me with that issue?

Thank you!
Andriy

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu language-selector Edit question
Assignee:
No assignee Edit question
Last query:
2012-01-01
Last reply:
2012-01-01
Gunnar Hjalmarsson (gunnarhj) said : #1

soulcor,

Sam_ linked to a bug report where this issue has been addressed. If you don't want to wait until the bug has been fixed, you can install language-selector from my PPA at https://launchpad.net/~gunnarhj/+archive/misc

/ Gunnar

P.S. Why do you call gnome-language-selector as "sudo"? You are not supposed to do so, and it may make you encounter other kinds of unexpected behavior.

Can you help with this problem?

Provide an answer of your own, or ask soulcor for more information if necessary.

To post a message you must log in.