11.04 system/language doesn't run

Asked by y.alasehirli on 2011-05-12

my language doesn't install properly.i did first login,i took a warning about that.but i skip the warning,because i haven't internet connection.after that i click the language in system settings.it didn't run.i try again and again,but it doesn't.what can i do?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu language-selector Edit question
Assignee:
No assignee Edit question
Solved by:
Gunnar Hjalmarsson
Solved:
2011-05-14
Last query:
2011-05-14
Last reply:
2011-05-13
Salih EMIN (salih-emin) said : #1

There are some missing packages that you need Internet connection to get them. First connect to internet and then open language support again. If it prompts you to intsall additional packages do it.

y.alasehirli (y-alasehirli) said : #2

my problem isn't install packages.my problem is that my language support of system is not running.click,more click to language support,but it doesn't running.how i work language support?

Salih EMIN (salih-emin) said : #3

Burda bulunan ( http://osarena.net/2011/05/video-egkatastasi-ellinikou-perivallontos-ke-pliktrologiou-iqunix.html ) videoma bi goz at, videomda yunaca konustugum icin ozur dilerim, ama eger sesi kapatip, haraketlere goz atarsan, aynilari turkce dili kurman icin gecerli. Internet baglantisi lazim.

y.alasehirli (y-alasehirli) said : #4

@salih emin
videoya baktım.language support'a tıklayınca bişi olmuyor.açılmıyor language support.benim problemim orda.nası çalıştırabilirim acaba onu diye soruyorum.yardımların için sağol

Salih EMIN (salih-emin) said : #5

Ilginc bi problem gercekten... O zaman "Synapti Package Manageri" acip asagidaki paketlerin sisteminde kurulu oldugundan emin ol:

--language-selector
--language-selector-gnome
--language-selector-common
--language-pack-tr
--language-pack-tr-base
--language-pack-gnome-tr
--language-pack-gnome-tr-base
--language-support-fonts-tr
--language-support-writing-el

Eger kurulu deyilseler, o zaman kurmalisin.

Salih EMIN (salih-emin) said : #6

Afedersin, en sonuncu packet yanlislikla "language-support-writing-el" olarak yazildi, dogrusu "language-support-writing-tr" olacak

y.alasehirli (y-alasehirli) said : #7

TR|| dili türkçeleştirdim bu paketlerden eksik olanları yükleyerek.fakat hala dil desteğine tıklayınca çalışmıyor.
EN|| my system language is turkish with suggesting packages.but language support still doesn't run.

Salih EMIN (salih-emin) said : #8

OK. Eger bu paketleri yuklediysen ozaman Logout yap, ve giris ekraninda Ismini secip, paswword'unu yazmadan, asagidaki (sol) dil secenegi kismindan, English listesine tiklayip "other" sec. Sunulan seceneklerden "turkish" dilini sec. Artik systemine girince, menulerin tumu turcelestirilmis bulunmali.

Gunnar Hjalmarsson (gunnarhj) said : #9

@y.alasehirli
I don't understand most of the previous comments, so there is a risk that I repeat what has already been said...

If I understand it correctly, you are trying to make Ubuntu display menus and messages in Turkish. As regards the "Language" tab in Language Support, it does not help to just click your language; it's a drag-and-drop control. For some more guidance on how it works, I suggest that you click the "Help" button in the bottom left corner of the Language Support window and select "Language Support" from there. Please also note that once you have moved Turkish to the top of the list, you need to log out and log in again for the change to take effect.

Best Gunnar Hjalmarsson (gunnarhj) said : #10

No, wait... Now I suspect that you have encountered bug #747796. If that's the case, you can replace /usr/share/pyshared/gi/module.py with the adjusted module.py I attached in comment #25 of that bug. Optionally you can install version 2.28.3-1ubuntu1.1 of the pygobject package from natty-proposed.

y.alasehirli (y-alasehirli) said : #11

@gunnar hjalmarsson
i read your #10 reply,and apply in my ubuntu.that is not answer for me.i explain my problem widely and step by step;
1.open system settings
2.find language support button under system section
3.left click for open or run it /right click on language support button then left click to start language support for open or run it.
4.my problem start after 3rd step.don't run language support.

that is my problem.i translate system language compeletely with @Salih Emin,but he don't solve my problem.

Gunnar Hjalmarsson (gunnarhj) said : #12

How do you know that the solution mentioned in my comment #10 is not the answer to you? That bug prevented Language Support from starting when a Turkish locale was selected.

But it's easy to find out:
* Open a terminal window
* Enter the command gnome-language-selector
* Let us know what happens.

y.alasehirli (y-alasehirli) said : #13

i read it.but i didn't know the language-selector = language support.i thought language-selector is different thing.also i try your answer,but i didn't copy module.py to target folder.i take access error.only root copt target folder.if module.py solve that problem,now i have a new problem.how i copy target folder?how i ' ll be root?

Gunnar Hjalmarsson (gunnarhj) said : #14

You become root temporarily by using the sudo command.

* Go to the folder to which you downloaded module.py

* Run:
    sudo cp module.py /usr/share/pyshared/gi

(you'll be prompted to enter your password)

y.alasehirli (y-alasehirli) said : #15

-i went to "downloaded" folder.downloaded module.py is there.
-press ctrl+alt+t for open terminal
-write sudo cp module.py /usr/share/pyshare/gi
*terminal gave an error.
"cp: 'module.py' not statued: file or directory not existed."
(error write in turkish.maybe i fail to translate to error english)

what can i do?i skip something?

Gunnar Hjalmarsson (gunnarhj) said : #16

I'm not sure what you mean when you say that you went to downloaded folder. You need to change to the Downloads folder in the terminal window after having opened the terminal. (Using e.g. Nautilus does not work.)

This is what it looks like for me:

[gunnar@gunnar-laptop ~]$ cd Downloads
[gunnar@gunnar-laptop ~/Downloads]$ ls
module.py
[gunnar@gunnar-laptop ~/Downloads]$ sudo cp module.py /usr/share/pyshared/gi
[sudo] password for gunnar:
[gunnar@gunnar-laptop ~/Downloads]$

The 'ls' command it's not necessary, but since it shows the files in the current folder, it's a way to confirm that you did it right so far.

y.alasehirli (y-alasehirli) said : #17

@gunnar hjalmarsson

thank you.your commands are working on my system.and now i open language support.

y.alasehirli (y-alasehirli) said : #18

Thanks Gunnar Hjalmarsson, that solved my question.

Gunnar Hjalmarsson (gunnarhj) said : #19

You're welcome. Glad to hear that it works at last. :)