GNOME wont load 10.04.1 LTS, 2nd part, the revenge

Asked by Giovanni on 2010-09-03

I'm return to the problem in question #123907.

The solution didn't work for me. Gnome continue to block in load process. If gnome load, nautilus hangs several times during the session.

I've searched for missing dependencies or corrupt packages, but nothing found.

Is there a way to debug the problem?

Thank you

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu language-selector Edit question
Assignee:
No assignee Edit question
Solved by:
Giovanni
Solved:
2010-09-30
Last query:
2010-09-30
Last reply:
2010-09-26
Sam_ (and-sam) said : #1

You could access recovery mode, try option 'repair broken packages'.
http://unixlab.blogspot.com/2009/08/exploring-ubuntu-recovery-mode.html

In case you don't see the boot menu, press [Shift] key.
https://wiki.ubuntu.com/LucidLynx/ReleaseNotes#No%20delay%20for%20boot%20menu%20with%20GRUB%202

Giovanni (druid-taliesin) said : #2

I've tried your solution, but nothing change :-(

Sam_ (and-sam) said : #3

Is your system updated?
sudo apt-get update
sudo apt-get upgrade

No idea, could be anything from graphic card/driver, Xserver, ureadahead, plymouth, gdm to whatever.
You need to examine log files (system administration -> log file viewer).
e.g. dmesg, daemon.log, Xorg.0.log
Only found this Bug #557930

https://wiki.ubuntu.com/DebuggingProcedures

Giovanni (druid-taliesin) said : #4

I reinstalled ubuntu and fall in the same problem when I changed locale from it_IT.UTF-8 to it_IT@euro (after regenerate locales).

I deleted .gnome2* .nautilus .gconf* directory, restart and I can access gnome again, but nautilus need to be killed every time.

Bye

Sam_ (and-sam) said : #5

> it_IT@euro

This shouldn't be generated in the first place. Please leave it as it_IT.UTF-8.
My locale -a doesn't output any ....@euro at all.

You may add yourself by clicking on top: Does this bug affect you?
https://bugs.launchpad.net/ubuntu/+source/language-selector/+bug/533159/comments/8

Sam_ (and-sam) said : #6

https://help.ubuntu.com/community/EnvironmentVariables

Maybe in this case valuable:
-quote on-
The below are not recommended but the previous solution provided on this page did not work with the 10.04 desktop release. .pam_environment is not naturally procesed with the distribution.
-quote off-
https://help.ubuntu.com/community/EnvironmentVariables#Session-wide%20environment%20variables

Giovanni (druid-taliesin) said : #7

Hi Sam.

I have @euro in my locale -a.
Anyway, I return to UTF-8, but nothing change. How can I return back to correct configuration? Don't tell me to reinstall all again, please.

Thank you

Sam_ (and-sam) said : #8

The bug report contents a workaround.
https://bugs.launchpad.net/ubuntu/+source/language-selector/+bug/533159/comments/9

Regarding suggestion #1 about the file /var/lib/locales/supported.d/local
Delete ....@euro
Also verify that in the directory /var/lib/locales/supported.d
isn't a ....@euro.

Although #2 says /usr/lib/locales/, I don't have such a directory, what I have is
/usr/lib/locale/
However, I wouldn't remove everything which is in there as suggested.
If it contents something like ....@euro I'd delete this only, (if that doesn't help, well, then delete all).

After done all this follow step #3
sudo dpkg-reconfigure locales

## In any case you should have backups, issue or not, when there is one it's too late.
## Make sure not to run any applications, e.g. updates, media player, firefox, email during the procedure.

Giovanni (druid-taliesin) said : #9

Now it seems to work.

let me test this for two or three days.

Thank you very much

Giovanni (druid-taliesin) said : #10

Ok, all went well, now gnome work perfectly

Thank you very much

Sam_ (and-sam) said : #11

Great that it worked out for you. Enjoy Ubuntu.