Ubuntu KVM guest gives "No valid session found" on login

Asked by Carlos De Matos on 2011-08-17

After a reboot today I got a nasty "No valid session found" error. Google searches have not helped but I see a lot of these as precursors to natty unity. I have tried logging in under classic and other non-unity sessions to no avail.

The problem seems to be with the xsession scripts.

Please help me with one of..

1. How do I fix xsession (everything is up to date)
-- OR --
2. How do I generate a default/standard xorg.conf that I can place in /etc/X11 so that xsession does not have to fire up its automated (faulty) detection...

I have tried most obvious things...

Thank you,

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu kvm Edit question
Assignee:
No assignee Edit question
Last query:
2011-08-17
Last reply:
2011-08-17
Chris (fabricator4) said : #1

You can generate a new xorg.conf file by typing:

Xorg -configure

Note that X can not be running when you do this or you will get an error message, and also the name really is Xorg, not xorg. This will generate a file called xorg.conf.new which you can move to /etc/X11/xorg.conf

Note that this xorg.conf will probably have the same fault, or it will be incomplete in so far as the true monitor information is concerned. You could try plugging the monitor directly into the machine just for the purpose of running Xorg.conf

I also run through a KVM switch and the problem is that the monitor EDID data is not passed though to the video card. I don't understand why your normal login works, but a secondary guest login does not - I would expect the problem to be the same regardless.

Chris

Can you help with this problem?

Provide an answer of your own, or ask Carlos De Matos for more information if necessary.

To post a message you must log in.