Ubuntu

Will ubuntu pull a newer version of KVIrc from debian SID?

Asked by ambossarm on 2010-03-25

Debian SID had now several new packages of KVIrc, but ubuntu does not automaticly fetch them.

It would be nice if KVIrc could be updated, because the newer version is more stable and secure

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu kvirc Edit question
Assignee:
No assignee Edit question
Last query:
2010-03-26
Last reply:
2010-03-26

Ambossarm,

Ubuntu does not use a "rolling release" strategy, meaning packages are not updated to newer versions during a release.

You might want to see if the newer version(s) are available in a PPA - you can search at: https://launchpad.net/ubuntu/+ppas

If there are legitimate security updates then you could possibly apply for a backport, details at https://help.ubuntu.com/community/UbuntuBackports

Best of luck,
George

ambossarm (ambossarm) said : #2

Thanks George,

the packages in karmic is broken and should never have been released.

But I meant the package in lucid.

greetings,
ambo

apt-cache policy kvirc
kvirc:
  Installed: (none)
  Candidate: 4:4.0.0~svn3900+rc2-1
  Version table:
     4:4.0.0~svn3900+rc2-1 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/universe Packages

That's the lucid version.

ambossarm (ambossarm) said : #4

http://packages.debian.org/sid/kvirc says sid has 4:4.0.0~svn4170+rc2-1 which is newer. Soon there will be svn4214.

I checked the version on http://packages.ubuntu.com/lucid/kvirc

But that is exactly my question, will lucid get a newer version and why has lucid a so old version when debian had several newer versions.

I am sorry if I was not able to make myself clear.

Log a bug showing the vulnerabilities in the current version which are fixed in the new version, it will be reviewed and updated.

ambossarm (ambossarm) said : #6

thanks for the answer.

What exactly do you mean with log a bug? Open a bugticket or just post here one?

If you mean here:
If you mean karmic:
The default script is broken, which makes KVIrc pretty unusable
http://www.kvirc.de/?id=news&story=2009.12.10.23.52.1.story&dir=latest
http://www.irc-junkie.org/2009-12-11/kvirc-ubuntu-karmic-build-is-broken/

If you mean in lucid, there are lots of bugs.
If you want only one - The most annoyed me the focus stealing, but keeping in background with gnome while joining a channel

https://svn.kvirc.de/kvirc/ticket/425

The newest debian build right now can be found on http://dev.carbon-project.org/debian/kvirc/
I was told, that that version will be in sid, as soon as the one before is in testing, which should happen within a week.

Newest builds for karmic are on http://www.rzuser.uni-heidelberg.de/~xt1/ubuntu/

What is the official proocedure to nag ubuntu to pull a newer version from debian for the unreleased version? Should I open bugtickets for that?

Thanks in advance!

 If you find a bug in Ubuntu or any of its derivatives, please file a bug using the command:

ubuntu-bug package

See https://help.ubuntu.com/community/ReportingBugs for other ways to report bugs

Can you help with this problem?

Provide an answer of your own, or ask ambossarm for more information if necessary.

To post a message you must log in.